Wd elements unallocated partitions

Hello. I have a 4TB WD Elements external hard drive connected via USB to my Windows 10 PC. The drive was being used as a single partition. Due to something rather stupid that I did I have now managed to end up with two partitions 2048GB and 1677.99GB. Disk Manager still shows the basic size of the drive as 3725.99GB. Both partitions are indicated as unallocated. Using Disk Manager (Right Click on the drive partition) I was able to allocate the 2048GB partition. However, there is no way that I can find to do the same with the 2nd partition. The option to create a New Simple Volume is greyed out. I don’t mind if I go back to a single partition or I have two but I don’t want to lose the huge amount of storage that I can’t utilize! Can anybody help me please? Thank you.


Have you tried deleting both partitions and trying to create just one?

You may also try writing zeroes using WD DLG then trying to partition the drive

Data Lifeguard Diagnostic for Windows

Many thanks for your reply and the suggestions. I’ve tried to delete the partitions. The detete option is only available on the 2048GB partition and all that seems to happen is that it goes back to ‘unallocated’. The only choice on the 2nd partition is to view its properties.


In this case I recommend you write zeroes to the drive using WD DLG.

Thank you for all your help Hamlet - success! It didn’t quite work first time in MBR format but when I changed it to GPT it converted both partitions into one. Hey presto, a 4TB drive.

Hamlet, I have the very same problem as Dapper, except my Elements is a 3TB. Can you explain, or provide a link as to what you mean by writing zeros to the drive using WD DLG?