WD Elements running but not showing anywhere in Windows 10

I recently bought a new laptop of Asus rog strix which runs in Windows 10. My 2tb wd elements was working fine in my previous lap. I connect my hard-disk to new lap and it got detected as usual. But after couples of days I found some time the hard-disk not detecting. And I would reinsert it into another usb and eventually it got detected. Yesterday I had the same issue. And connected to my phone using Total Commander App and was working fine. Then I tried again in lap and got detected. Today again not detected. And tried reinserting and I kept it connected. After 2-3minutes it shows the pop up window to explore the HDD and was working fine. Now it is not working. I tried reinserting. Tried to update all windows drivers using Driver Booster tool. Googled every solution. Tried disk management, drive letter method and I can’t even see any other methods online other than this. HDD is working as I can hear the sound. There is no abnormal sound nor any click. No flex and damage in wire. Can anybody help?
By the way, it is accessible through my phone

Hi shahinms,

If the drive is not detecting on your computer then refer the link provided below to troubleshoot this issue.

https://support-en.wd.com/app/answers/detail/a_id/12455