WD elements portable drive not recognized

My WD elements portable has stopped functioning all of a sudden. It tries to install the driver, shows up in device manager and “devices are printers”. No yellow exclamation sign and it says its working properly. It shows up in disk management as not initialized and when i try to initialize it gives the error “the system cannot find the file specified”

I’ve tried connecting this to multiple computers(windows 7, and 10) and I’ve tried different cable as well. the light stays on instead of the usual blinking. Also it beeps for a few seconds after i plug it in. Also tried the firmware update from WD which fails to update. many partitioning software to initialize the drive(minitool, easeus, seatools, AOMEI ) but they dont even list the disk, tried many options through diskpart as well which atleast sees the disk but wont do anything further.

Its still under warranty though. In case replacement is the only option, is there anything that can help me detect the drive atleast once and have me backup my data

TIA

Does it succeed in installing it?

Yes it does, just edited my post to add some more information if it helps

Try the steps mentioned at the bottom of the first page in this thread (user was having the same issue as you and claims this solved it):

Those steps will blast out all the data on the drive. You might want to restore your backups (if you have them) or go to Data Recovery (if needed) first. I’ll give you a link below to a list of our data recovery partners:

just tried initializing the partitioning as GPT, but failed with same error

Hello I am having same issue with my WD elements portable 1TB, it shows in my device manager, which I have installed and uninstalled but the drive is no where in sight no matter what I do. The WD drive utility tells me to connect the supported drive for my product telling me there is no drive connected for this. I have done everything what can I do? Oh and I have also connected the USB cord it came with, and several new ones purchased directly to the computer and still doesn’t work.

The system cannot find the file specified error occurs because the file system of the target device is corrupted or damaged, making your hard drive, USB or external hard drive inaccessible. To fix this error, you need to run the chkdsk command, to repair the corrupted file system, using reliable data recovery software to bring all lost data back. Then, clean and re-partition the hard drive using the diskpart command in CMD.

Hope it helps!