WD Elements Play with broken hard disk

I have a WD Elements Play WDBACC0010HBK-00 and broke the hard disk.
I replaced the piece but when poweron obtain the messages “Unable to detect the internal hard disk. Please check”.
I tried to create a NTFS filesystem with Windows 8.1 and with Linux ext3 and ext4 but have the same message.
My new hard disk is “Segate ST31500541AS” 1.5TB.
Please, someone can I help me?

mmmm…I can’t replay at the post below!!!..incredible
I can’t post in the “WD Elements Play” forum. I lost my words.

This topic will be moved to correct forum.

Maybe try deleting all Partitions (making the drive a RAW drive) … insert the HDD into the WD Elements Play and format the drive using “Disk Manager” (Page 42)

I deleted the partition but when start the device or go on the “Disk Manager” on page 42 obtain same error. “Unable to detect the internal hard disk. Please check”.
I tried with another hard disk Hitachi 1TB but the error it’s the same.
Maybe is it the electronic is broke on my WD Elements Play or support only specific models of disks?

oh well, it is a pretty old device … but you should be able to use it without a internal HDD

The WDTV Live Hub will work without it’s internal hdd … just click “ok” to ignore and plug an external hdd into the usb ports.

OK, thank you.
I think there is only this solution :frowning:

èè noooooo…

I found the solution. The hard disk must be “Western Digital” (…It may be obvious) and the “First sector” MUST be 63 (Disklabel type: dos)