WD elements play HDD issue

Hello guys,

I recently ran into a problem. I got this new elements play 2TB, well because frankly it was awesome. Plays everything, and subtitles and directly connects to the tv. Anyhow, I realized immediately that there was this weird issue with “security” that made me have to allow myself (even though administrator) to access the file every time I plugged in the drive into the PC. You know, when you have to go to properties, security and fix it. This was no normal problem because it could not really be fixed and I had to do it every time. So I moved all my files to the PC, formatted the drive and moved the files back. I do not recall that something happened. But then one time when I plugged in the WD the autoplay did not trigger, I thought to myself “weird…” went to my computer, didn’t show… again i thought weird… I saw that the drive was recognized though because the safety removal had it adressed as “multimedia 0620” for some reason and not elements play anymore. And I am fairly cunning with computers so I come here as a last resort. So I enter diskmanagement, and My drive is listed, but not assigned a letter, and when I right click the only option that shows is “help”… no assign letter and so on… and when i scroll down, it says healthy (recovery partition) so everything seems fine. except that the white area under the blue bar is diagonally striped and says that the ENTIRE disk space is free, which i know is not true.

Anyhow this was possible to bypass by entering diskpart in commandprompt, there I listed the volumes and on my multimedia drive everything seemed fine except that the info was “hidden”. I assigned it a letter anyhow and viola the disk showed up in my computer. all the files where there and completely accessable with no problem. But as soon as I plug it out when I am done, and plug it in again, we have the same problem. The letter the drive had assigned to it becomes instead an empty “local disk” and I have to assign a new letter to my WD if I want it to show. I have no idea how this happened to be honest. And less of an idea of how to fix it. I have literally tried eveeything in my knowledge and no one in any forum or help site have had any similar problem.

I few things to know.

  1. Hard drive is fine as I mentioned, no corrupt files and they are all accessible after assigning them a letter using diskpart in commandprompt.

  2. Not only MY PC that has the problem, it is with every computer.

  3. I am not completely sure but I think the disk might return to normal if I format it. But I would like to avoid trying to find that out, I bought a 2TB HDD so that I do not have to store media on my computer, so I would lose A BUNCH of files if I would have to turn to that.

And I apologize for the long message, but I needed to make sure I explained myself so that I can avoid follow up questions as much as possible.

Thank you for any help :slight_smile:

Have you tried to scan the drive for errors using Windows Check Disk?

cuernudo wrote:

Have you tried to scan the drive for errors using Windows Check Disk?

Yes, I really meant it when I said I have tried it all hehe… But I like your thinking, because there is clearly something going on with the disk itself. I tried to look for firmware, but all I found at WD was the GPL code, I do not think that would help and installment of it is beyond my knowledge anyway.

I suspect that the the first format, and the only, I did was the cause of maybe the “system files” dissappearing, because there are no more hidden files in it. But the disk was working fine after the format, it just randomly happened afterwards.

ONE interesting thing though, if I had the harddrive plugged in prior to to turning my PC on it used to stay at the screen at the beginning with the _ flashing as if it wanted to boot from the disk, and the disk light was flashing as well, but with no result, just staying on that screen until I restart and plug out the drive and plug it in after windows starts. well, THAT doesnt happen anymore…

Ok guys, I am now moving all the files I can move to my pc, granted some files will be lost, lack of space.

Anywho, I will format it afterwards, an attempt to get the autoplay back and all that. so is there a “sure” way to format?

I have used the righ-click windows format for as long as I can remember and have never had any issue, but to be sure this time. And does the firmware dissappear when I format it? (can not see how it would, but a silly question to be on the sure side :P)

Have you tried my method ?


1 Like

Smeagoul wrote:

Have you tried my method ?


Yes, I believe so, not in the same manner as you did. I had the same problem as you though, that the disk was recognized and shown in diskmanagement but one could not do anything with it. My simple fix was commandprompt, since I do not like depending on 3rd party software to fix something that should be fixed with windows itself. you could either enter diskpart through commandpromt or windowsorb and search “diskpart” and run it, “list volume” and see what number your disk is, “select volume #” then “assign” and the first free letter will be assigned for it and the disk will be up and running in my computer, but the issue is, when you plug it out, you have to go over all this again next time, which I believe is the same case with the software you promote (that one would have to use it to assign a letter for the disk every time its plugged in".

I got sick of it though, so I put as much files i as I could back on my PC, formatted it and now put them back.I just wanted to avoid that because it takes a little above 6 hours to move almost 1TB of data, and then the same amount of time to move it back to the ext. drive… not to mention the data I lose everytime I would have to do this since my ext. drive is 2TB and my PC´s only about 800 gb…

Thank you guys anyway, I will chose your answer as a possible solution (best choice if one doesnt want to format) to close this thread or subject.

Well, actually the most important part is to change the disk partition type to NTFS with the software, that’s the one that “brings it back to life”, that’s why I used it

I have the exact same problem. Thank you very much for telling me how to make my computer read back my HDD again.

I have copied back and forth all my 1,8 TB files to different disks and computers three times. I found out that I could copy around 1,3 TB without losing data, but every time I surpassed such limit my HDD crashed and turned into a Multimedia 0620 instead of a WD Elements Play and all the rest of the things you’ve said. Don’t close this please, let’s see if someone comes up with a better answer. And thanks again.

1 Like

I’ve a problem in my WD Elements Play

It used to work just fine.

Suddenly I can check all my movies with my laptop. But I can not watch a movie using it or even view the menu !!

What’s the problem ?

What should I do ?

1 Like