WD Elements PC problem


I’m new in this forum, first time with an issue with a drive, and it’s a weird one.

Iv’e been searching some posts to see if someone had the same problem, but dind’t find anything.

When I plug in my drive to any PC, it shows as WD elements in the devices, but I can’t access it, nothing can be done with the drive on any PC. But if I plug it in my TV, there is no problem, I can see every file in there and use them with no problem.

Any idea on haw I can get the drive to work again on a PC?

Welcome to the Community.

Have you tried Disk Management? It is possible for the drive to need a drive letter in order to mount.



Thank you.

I have tryed disk management, the drive shows, it has a letter, but if freezes and I can’t do anything, I have to force shut down disk management.

I have tryed updating firmware, didn’t work. Tryed WD data lifeguard, and it gets an error and cant do the test. Something is really wrong here.

Do you have a backup of the drive’s data? You may need to format it.

I tryed different windows, none could access the drive. After trying many different HDD recovery software that didn’t help at all, I decided to try the simple old school method. Just ran the CMD, did the CHKDSK /F, and after it was done, my drive was visible again, and working normally.

Problem solved.

1 Like