WD elements dont recognize .MTS files


#1

Hello.

My father have a sony camcorder that records files in FullHD in AVCHD format… The file extension is *.MTS

I bought a WD Elements Play but this device is unnable to recognize MTS files (i cant see them on the browser of the device)

I tried to make some copies and change the file type, the result is (for the same file, without any conversion… just change the *.MTS to other name):

file.MTS -> Device cant see the files

file.M2TS -> Device see the files and plays without problems

file.TS -> Device see the files and plays without problems

My firmware version is: 1.01.10 (updated today)

Since this device is for my parents and i will be out of country, is there any way that the device can see the MTS files without renaming all the files from MTS to M2TS… Because my parents understand almost nothing of computers and nothing of english… so using even a software is out of question… They what just to copy and paste the files from the camera to the media player…

I need help please… I will leave portugal this sunday :confused:


#2

Well if they can’t rename a file, how are they going to load new files on it? ;). Renaming is certainly easier tha copying…


#3

Hello,

I had the same issue WD elements play not playing .mts files. Renaming them without a computer is not possible.

But I have another issue with sony camcorder AVCHD files. After renaming them (to .ts or .mpeg), WD elements play plays them without a problem but stops before the end of each file. For example, it stops after 25 seconds of a 35 seconds file. The little preview window shows the total clip.

Does anyone know a fix of this?

I have formatted the box to MAC OSX journaled.

Best regards,

Luc


#4

Hi,

I also have a sony camcorder which records in AVCHD. To play on WD elements play I also have to rename the files from .MTS to M2TS, which is quite time consuming but also the player flicks onto the next file when there is about another 9 seconds still remaining of the previous file. I also would like help with this problem. When I tried a couple of different file extensions on a USB memory stick the elements play played the whole file so may be something to do with how it deals with files in a folder

Thanks

Kianga