WD Elements 500 GB unable to safely remove (Win10, tried everything)

Hi all,

I just recently purchased my WD Elements 500 GB, and I noticed that I’m unable to remove it safely on my Windows 10 x64 PC. You know, when you go to taskbar and search for that “Safe to remove” icon.

I have tried everything.

  • Tried to update firmware
  • Tried to download USB Disk Ejector (suggestion on some other forum)
  • Tried to turn off my Antivirus


As you can see, there is no option to safely remove the device:

USB Disk Ejector says

Oh yeah, I also tried to remove it via WD Smartware, but I couldn’t find the option there either.

I’m out of ideas.

Any kind of suggestion would really be helpful.

Thank you.


I forgot to mention I don’t have “quick removal” option in the Device Manager, at all.

I also tried to disable Indexing on my drive, but that didn’t change anything. USB Disk Ejector still says the drive is in use, and I still don’t have an option to remove the drive safely. :frowning:

I have no idea why is this happening, but I did find unanswered questions regarding that issue on the web. And I’d really want to get an answer for mine :slight_smile:


Make sure that you don’t have a backup software running on the background.

Thanks. I don’t. Even if I did, it wouldn’t explain why I don’t have an option in the taskbar to safely remove the drive :-/