WD Elements 4TB works on USB 2.0 but not USB 3.0

The product is a 4 TB Elements WDBU6Y0040BBK-WESN drive advertised on Amazon as intended for USB 3.0.

It works on USB 2.0 but not on USB 3.0.

I purchased the drive to replace an older external drive that had been plugged into my USB 3.0 port, so I know the 3.0 port works.

The WD Elements 4TB drive, however, would not plug and play when I plugged it into the USB 3.0 port. It did plug and play immediately on the computer’s USB 2.0 port.

WD support is suggesting, in what appears to be a form letter, that I update the Windows drivers. I use Win 7 and it is fully updated. And it not clear how to update a USB 3.0 driver when the drive only works (and shows up in the device manager) on the USB 2.0 port. If I pushbutton update the driver in this system, it will necessarily be the 2.0 driver, not the 3.0 driver, it would seem.

What should be the next step?

Thank you for your insights. John

But are your Motherboard Drivers fully updated ? (i’m using a Gigabyte MOBO Windows 7 … 4TB Elements and 4TB My Passport Ultra work fine on USB3.0)

The other simple thing you can try is using a different USB Cable and/or try plugging it into a different computer … if the problem persists then that eliminates the cable and PC as the problem.

Thank you for your help, Joey. I pursued your driver suggestion and
eventually solved the problem. I went to the device manager and
identified the USB 3.0 devices, and they are associated with or products
of Renesas Electronics. Apparently most Win 7 machines have them. I
tried updating the drivers within the Device driver, but Windows
insisted they were already up to date. (To get ahead of the story, they
are not in fact up to date.)

I then went to the Intel Driver site and searched on “Renesas USB 3.0”
This brought a number of responses. My installed driver for the USB 3.0
Host Controller, however, was numbered 2.1.27, and Intel had on offer a
driver numbered 2.1.28. Hard to resist. This is where I found it.


I downloaded the installation software for this driver and ran it.
Voila. Plugged in the 4 TB Elements driver and it finally ran on the
USB 3.0 port. Worked on my machine, but of course it might or might not
work on a different machine.

Thank you for your excellent idea. Regards, John

Good to hear you got it working :slight_smile: