WD Elements 2tb, i/o error, shows unallocated, HELP

Really appreciate any direction. My son who produces music just brought me his back up drive with a problem. He had just the day prior, moved all his music files and projects to his back-up drive to clear space on his PC. He was supposed to up load his album to a internet music streaming service/radio station to go on their play schedule. His luck, he first couldn’t see disk anymore in “my computer”. Brought it to me, I’m running windows 10. Plug in, same issue. Pull up under disk management. after a while it shows up, but as “unallocated”.

Try to initialize, but get I/O Error. Removed from enclose, try booting up on 3rd party card, same thing. Try getdata recovery and easeus data recovery, no go finding files. Have read could be circuit board on drive. Don’t think controllers as issue since My 3rd party one works fine. Any suggestions? Data recovery services charge over $1,200 with no guarantees which is tough for a struggling musician trying to meet a deadline to upload his music. It had a year worth of music and production on it.


I/O error is normally related to either one of the connections on the drive or the PC that you are using.

Did you tried using a different USB cable?

Hi, thanks for your reply. Yes I have used 3 different USB cords which I know are reliable with same result. I also hooked the drive to a different controller card than the one that was in the enclosure, with the same result. The light blinks and finally settles to an even glow once the drive is seen in disk management, though it isn’t seen in MY COMPUTER still. The whole drive shows in Disk Management as being an Unallocated Drive. If I try to initialize it with either of the 2 options offered , that is when I receive the I/O error. Unless someone has a better idea, I’m thinking it’s the actual Data Circuit board that’s attached to the drive with those small torx screws or something went wrong with the platters where I can safely say a year of work is loss to him.