WD Elements 2TB External hard drive BLINKING LIGHT Problem

Seagate

i have 2 externel hard drives and both just blink, can get some help with them, i realy need the data.  HELP!   thanks  PS: one is 30gigs and one a 250 gig.  there is no spining in both drives, just a blinking light.

I stupidly bought 2 of these, luckily ones backup. I get the blinking light and not mounting thing all the time on one of the drives, when it does it using my macbook I mount the thing in windows shut down and it would then work on the Mac again. Same thing vice versa.

I also have Ubuntu on my desktop, debian on a raspberry pie, and a ps3 and strangely the drive never fails to mount on any of these and is always readable after I get the blinking light on windows and OSX. Maybe Linux is the answer to your lost data issues.

A solution to try before expensive data recovery or trashing the HD may be to download a Linux based OS like Ubuntu, burn it to a CD and boot your Mac or pc from it. Completely free (apart from a blank CD) and no need to install anything, the OS will work straight from the CD, well worth a shot.

Had faced with the same problem of Blinking lights for my 1TB Western Digital External Hard Drive. I attached my WD on another pc. Fortunately it got detected and after sometime a message appeared “the recycle bin of the drive has been corrupted. Do you want to empty the recycle bin ? I said yes” and it emptied the recycle bin and now my WD External is working absolutely fine.

:wink:If you want the data off 2tb you have to get second hd if aleady have 2 hd of same type get disk from the non working one and put in working hd problem solved

11/13/2012 - SOLVED (for the blinking light on power-on).  Okay this was a really dumb idea.  But all I did when I turned it off and it wouldn’t turn back on (unplugged everything and kept the power off for at least 30 minutes and still only got the blinking light.  I stuck the My Book in the freezer for 5 minutes.  (Yes…that’s what I just did.)

Just took it out, with a cold plastic case, plugged it in, and it powered on perfectly. 

I have never had to refrigerate a USB hard drive controlller to get it to reset, but this is totally new on me.  Chill it.

The blog post to why I have 3 of the My Books and what I’m doing with them:

http://jhlui1.wordpress.com/2012/11/07/western-digital-my-book-111a-this-media-is-write-protected-read-only/

---- Original post

Yes, solved - sort of.  I actually bought 3 of them because the internal drives were cheaper than buying them raw.

First one had the powered on properly only after leaving the power supply unplugged from it for at least 6 hours (bad capacitors maybe?).  Eventually that one gave up after about 3 days and never came back on.

Second one also has the 6 hours off, then it starts up fine, but only if the USB connector is unplugged when first turning it on and then pressing the power button and holding for a couple of seconds.

Third one I use as a swap-in for the SATA-USB boards.

One thing that is very suspicious is that if the power supply (wall wort) is swapped with the one that came with the 3rd unit then the unit starts up on the first try (at least very often compared with using the 2nd power supply.

I’ll probably put these 12VDC things on a multimeter to figure out why some of these are so out of spec, but that last comment about it being power supply-related seems to be on-target.  Never quite gets enough current going to spin up the drives sometimes.

I   I have an WD Elements external drive 2TB and I have the blinking light problem too. It doesn’t show up in my computer either. i tried changing the USB and power cord and no luck. This unit **bleep**!!! I had it for less than a month… Customer servie **bleep** as well… I will never ever by another Western Digital product again!!!

This is not necessarily a hardware problem.  I went through the whole shebang too - plugging/unplugging, rebooting, blah, blah.  The first time, I was able to get the drives back.  It was one of either two things:

  1. I had done a strong cleaning of the registry.  It was perhaps too much, in which case when I did a rollback, I replaced a previously expunged value.  Or…

  2. It was a manual cleaning of the registry where I removed references to Western Digital.  This might have permitted the drives to reinitialize somehow.  Unfortunately, I did not make a record of how I found the entries.  Thus…

…here I sit with a blinking light which I don’t know how to fix.  (This arose after a system hang and had nothing to do with a registry clean this time).

The hardware is recognized under Device Manager and Disk Management and is reported as healthy.  Disk properties, though, show the data in RAW format (instead of NTFS) and the disk as 100% unutilized (not so), so it’s much as a stinking CD that doesn’t mount properly in an optical drive.  It looks like a logic problem.  I wrote a scathing letter to WD and expect a reply any minute now.  (Uh huh, any… minute…)

Hah, just got it working.  So here’s another possibility…

just browsing around, I found someone’s link to a Windows troubleshooting tip which suggested unplugging the drive,  disabling any antivirus software, then plugging back in.  That seems to have done it for me this time.

WD elements desk top, 1TB drive was formerly formatted and used with Windows. I have downloaded the Mac reformatting program from WD and the drive appears on my desktop but I am unable to get the drive to accept the reformatting program. I understood this would be a relatively easy task to change the used drive over to Mac.

Any help or where to go or method to make the drive useful for a backup drive will be appreciated.

Don’t know who told you Seagate is any better than WD as my 2TB Seagate is performing just the same…doing nothing

Hi all who have problems with this type of WD external HDD
http://support.wdc.com/product/images/groupfs_304.jpg

I have 3 WD external hard drive enclosures! light on the box flashes constantly without hard disk starting up! tried a drastic method! had a wire from the multimeter to short between 2 of pinene on the s-ata plug suddenly woke up hard drive to live everything worked fine!

any case one WD external hard drive!
With the other WD drive way I do this all the time every time I connect WD HDD rather start up my computer time!
No HDD’s fault! But the electronics inside the external box

stopped short just in 1 second

Could not make good sense out of your problem solving. Since I have the same probem with a 2 TV WD External harddrive would love to see a solution. Maybe thishelps anyone wanting to give some advice, the WD worked fine on Windows 7, at the end of October 2012 put Windows 8 on the computer and this WD 2 TB does no longer work, neither does an IOMEGA 1 TB so the problem is not exclusive to WD. On an older Windows 7 system all these work fine. Anyone any idea how to solve, I hesitate to put the darn ting in the freezer as someone suggested some weeks ago.

If WD external hard drive works in win7 but not in win8
then the operating system there is causing it! You can ask some data stores either where WD is sold.

I do not like win8! do not bother install win8 before arriving Classic View
son similar to win7

but if WD flashes constantly, no sound from the WD HDD!
so you can try to open the drive to short out the sata connector
helped me! sata plug the small connector

short circuit just in 1 second! not short-circuit a long time!

use anything eaten and short-circuit between pins
when shorting nothing happens until you take away the short circuit!

Yeah, I asked in the store where I got the WD external Harddrive - 2 Terabytes, what they told me, well you can either  FORMAT THE EXTERNAL HARDDRIVE…… It is clear that there is a problem with Windows 8 and Western Digital should know about that and have a fix for it. To format a backup hardrive is the stupidest answer I ever even wanted to hear.

Still no solution to the problem.

I’ve had this same problem with a 1.5TB Western Digital Elements drive for about a year now. As far as I can tell… the flashing light means that there isn’t enough power. I’ve read on other sites of people who have the same problem and they seem to point towards it being something to do with the power supply as well. I even read in one topic, a guy with the same exact problem, bought an alternate power supply and it fixed the problem for him.

To back this up, I just had my hard drive unplugged to free up a USB port. As usual, when plugging it back in, I have to really mess with the wires and tap on the casing to sort of kick-start the hard drive. The light hardly ever stays solid and keeps blinking, but I CAN still access everything on the drive. Well this time I couldn’t get my drive to stay recognized. It would keep connecting and disconnecting while I wasn’t even touching it. So I unplugged both wires from the drive and my USB port, reconnected them as usual and couldn’t get it to come on at all. I played with the USB cord first and got absolutely no response. I twisted and pulled on the power cord and would get a flicker of light. Then I pulled the power cord out, slowly pushed it back in and watched the light come on and start blinking. At that point it still wasn’t being recognized so I gently pulled the power cord out just a tiny bit… Now the light on my Elements drive is solid and stays on constantly unless data is being read.

Same drive - bigger problem - light blinking and it’s not spinning/powering up.  It was running previously but started making a lot of noise so I powered it down and I’m sure it’s gone now.

WDBAAU0020HBK-NESN - 2TB WD ELEMENT

OPENED UP AND IT WAS A WD CAVIAR BLACK - WD2001FASS

Just BARELY out of warranty and it is stone cold DEAD.  These drives are trash.  Unfortunately I bought two of them - but at least the other one is running still for the moment.

@ShotGal

Wow, did not know some of the old 2TB Elements contained 2TB Black drives. Black line is pretty good.

I would wager your drive is fine but the power adapter/circuit board is dead. Often companies skimp on this key area. If you place your hard drive into a computer and connect it I would bet they are fine. Or you can buy a separate (empty) external enclosure and put the hard drives in them.

Been having this problem for a few days and just figured out what my problem was. It seems that power is the issue as my drive will blink and run for 10 seconds and then turn off on my macbook pro laptop when the charger is not plugged in, but works fine when charging. Hopes this helps others.

I own a WD Elements Desktop 2 TB using OSX and have the same blinking light problem. After reading all pages within this topic. I still haven’t figured out what I should do to get my data back. To sum up the knowledge about this issue so far:

Problem: WD Elements Desktop USB2 HDD(External powered) DRIVE NOT RECOGNIZED by any OS or disk utility.

Symptoms: Known as “Blinking Light” problem. The light on the drive only blinks after plug in the powercord. There is no noise from the drive through spinning.

Suggested methodes:

1. Put the HDD in the fridge for 6 hours, which may influence the state of the hardware/capacitors.

2. Shortcircuit the drive for a second. To give it a “reset”.

So far WD hadn’t respond. If your drive still has warranty. Your drive will be replaced, BUT you will lose all data! If your data is more valuable than your drive. You can try methode 3.

Option3 : Open the case. Get rid of the USB case and plug your HDD direct to the computer (as an internal HDD).

If your data is valuable. Just skip the suggested methodes 1 & 2.

Please respond if you can get your data back successfully.

Good luck…