WD Elements 2TB disconnects (Error 0x80070037) when using USB 3.0 port

Hi guys,

Just bought a WD Elements 2TB USB 3.0 external hard-drive and I’m running in to a really frustrating problem.

Whenever I have the drive connected to the USB 3 port I lose the connection when transferring files, windows explorer closes and the hard-drive disappears for a while and then pops back up.

Sometimes it gives a message saying the files couldn’t be copied  and gives the error code 0x80070037.

Sometimes it just says an error occurred and the destination location doesn’t exist, this one seems to happen whenever copying larger files while the error code 0x80070037 happens whenever moving smaller files like pictures etc.

This only happens when using the USB 3.0 port, works just fine on the 2.0 port. And I haven’t have ANY problems with other external drives or devices using USB 3.0.

I have an ASUS U46S with Windows 7 64-bit with all the latest drivers.

I’ve goggled and it seems others are having similar issues with new WD portable drives and USB 3.0.

Anyone with an idea of what this might be!?

Thanks in advanced! :slight_smile:

Hello, it’s possible that the Elements is not receiving enough energy to work correctly. Check if you have any power saving modes enabled. Some laptop models lower the USB voltage when not connected to power. If possible you can also try connecting the Elements to a desktop PC with USB 3.0 ports and verify if the problem continues. Follow the link below for another step you can try.

How to test a drive for problems using Data Lifeguard Diagnostics for Windows 

Hi anmihe,

Your laptop has a Fresco Logic USB 3.0 controller, which is known that certain driver versions cause WD external devices to connect/disconnect randomly.

I would do the following:

(a) Upgrade the firmware of the drive to the latest using the WD firmware updater.

(b) Downgrade to older USB 3.0 drivers.

I have blogged about this problem and how to solve it here:


good luck.

1 Like


…you sir, are the [Deleted] MAN! :laughing:

Works great, thanks a lot for taking the time to share!