WD Elements 1TB will not install correctly.. help!

Yes i realize it’s rediculous…

I got this external hard drive as a present brand new in the box and everything, so i am not currently trying to put stuff on it, however, when i plug it in (yes, it is plugged into both an outlet and my usb drive on my laptop) but it refuses to be recognized. I am running on windows 7, and all i want to do is use this thing, please help me :confused:

Thanks again

Have you tried it in different USB ports without a hub? If possible try on another PC.


Yes i have tried both of the possible USB ports and neither do anything. Literally nothing pops up, or is visible to my computer. The device blinks a few times then goes to a solid white light, and i cant find it in the devices nor in my computer… thanks for the response(s)

Hello, anyone who reads this post and has this problem. i recommend doing this as it helped me and now my device is working perfectly fine.

-Make sure your device is plugged into a USB port (even if it is not being recognized).

-Open command prompt (Start Menu>Accessories>Command Prompt), right click and run as administrator.

-Type this: sfc /scannow

-Let it run (this may take a few minutes).

-Afterwards, take it out, and plug it into a different USB port (if you do not have one, unplugging and replugging it in should have the same effect i would assume…)

After i did this i could plug it in and it would open with autoplay, no problems at all.

If this doesn’t work for you i am sorry, at least i gave 1 solution that might help :stuck_out_tongue: