WD Elements 1TB problem

Hello. I just bought a WD Elements 1TB 2.5’’ external drive. I plugged it into a USB 3.0 root and it worked the first time. Then I tried to copy some files onto it and it suddenly said that these files do not exist on the computer, even though I just clicked on the file and dragged it into the drive. I unplugged the drive and restarted my pc. Now whenever I plug it into the USB 3.0 root, they both die. They don’t work anymore so I have to install the USB 3.0 driver again and again. Now, if I plug the drive into USB 2.0 it works, but obviously alot slower and that’s not what I want. 

When I plug it into the USB 2.0 the light on the external drive comes on and inside theres a continious spinning sound. So it works, but when I plug it into the USB 3.0, not only do the 3.0 USB’s die, but the light comes on for a second and then turns off and theres no sound at all. In devices on my computer it says that the device is working properly, but it doesn’t detect it at all.

Any suggestions?


Try updating the drivers for the USB 3.0 Hub. Also take a look at the link below. Hope it helps.

Problems using a USB hard drive with a USB hub, PCI card, or PC card