WD Elements 1Tb not recognised on PC - wd10jmvw-11s5xs0

I recently bought a 1Tb Elements portable HDD (purchased in Dec 2012)…of which it has been used twice a week at most. Hasn’t been dropped. No moisture. Looked after better than your factory would.

Working fine on Wednesday…then tried using it on Thursday and the frustration begins…

The drive spins up, LED lights up and continues to flash constantly…PC makes a sound when connecting the USB. Says installing drivers…then nothing else afterwards.

I’ve plugged it into multiple PC’s and with different cable to eliminate possible problems, but still no luck.

I read up on the Scorpio Blue drives or people with them…wd10jmvw-11s5xs0…is a problem. It’s either the PCB or firmware that I’m having trouble with.

I need this sorted as I have information on there that I simply cannot afford to lose.

Gettign help or in contact with WD is like finding water in the f***ing desert.


Have you checked the drive status under device manager and disk management?

Click on start/Right click on comp/click manage/device manager… look for any yellow triangle under universal serial bus controller

Click on start/Right click on comp/click manage/disk management … Look for disk 1 or disk 2 or whatever the comp assigned it.

Can you see any unknown disk? disk which is unallocated or with black long bar