WD Elements 1TB is useless - transfer speed under 300 KB/s

I’ve tried the following, and USB transfers are still horribly slow. I’m running Win7Pro 64-bit.

  1. Plug drive into back USB port, not a hub.

  2. Turn of search indexing temporarily.

  3. Disable Superfetch and Remote Differential Compression.

  4. Run these commands:

          netsh int tcp set heuristics disabled

          netsh int tcp set global autotuninglevel=disabled

  1. Device Manager > Elements Drive > Properties > Policies > Better Performance.

  2. Turn off Background Intelligent Transfer Service

  3. Move USB keyboard to a different bus than the Elements drive.

  4. Tried copying files to the drive from four Linux distributions (Mint 13, 15, 16, Xubuntu). Speeds were still awful - started at 15-20 MB/s and within 15 seconds slowed to under 200 KB/s.

  5. Checked Device Manager power and speed settings for the Elements drive and USB hubs. All are high speed and 500 mA.

If you Google “WD Elements slow,” you’ll find that the problem goes back more than 4 years, with no full-coverage solution offered by WD, Microsoft, or seemingly, any independent techies on forums. If I don’t find a solution soon, the drive will go back to Fry’s.


Such performance issues may indicate an issue with the device. I would recommend performing a complete drive test using Western Digital LifeGuard Diagnostics for Windows to confirm SMART status and a sector scan. If the unit is to pass the tests, then a complete low-level clean (Write zeros) would be the next step.

Additional information is available in the following link:


It passed DLG with flying colors. Speed is consistently 7-8 MB/s now. I know the drive itself is okay, as it will start transfers at up to 40 MB/s but quickly slows to 7-8.

What type of AV software do you have? You might try disabling that and test the transfer speed again.


Will try that - using MS Security Essentials.