WD Elements 1 TB lights on but not showing on computer on windows 10

WD Elements 1 TB external hard drive is not showing up on Lenovo IdeaPad 320-15IKB - windows 10

When the wd elements 1 TB external hard drive is connected to Lenovo IdeaPad 320 - 15IKB (Type 80xl,80ye), the light of the hard drive is continuously on but the device is not shown on my computer. the device is also not visible on computer management -> storage and also not show in device manager.

And the moreover…the hard drive is visible at times and is working fine but suddenly stops detecting. for say, the device got detected and I start copying some file…in the middle of copying the drive automatically disconnects even though the light on the hard drive is still on.

I tried uninstalling and reinstalling of universal serial bus drivers. but no solution.

the hard drive is working on other laptops with both 2.0 and 3.0 ports. but it is not showing on Lenovo IdeaPad 320 model.

please help.

Hello joshit.mohanty,

Please follow the troubleshooting steps mentioned in the below link:

I have the same problem, I tried all the instructions and installed wd elements on each computer. but the light is on and is not visible on computers. It just says what it is in the system information>USB section and that’s it. I need to access the files inside and import what’s on my computer. I am in a very difficult situation and I am afraid to make a guarantee.