WD Elements 1.5 tb stopped working after 2 uses

I have tried the smart software WinDlg the WD Quick Formatter and on three different devices but the drive refuses to be recognised or flicks on and off repeatedly with a flashing LED. I’ve also tried data recovery software and find and mount software but the drive reports an error everytime.

This is fully packaged new item and I have been working with computers for 20+ yrs unfortunately still stupid enough to trust a ‘reputable company’ with my data and therefore I have transferred data that has now been ‘cut’ from it’s source.

Anybody got any solutions? I’ve tried everything on the forum that I can find

I get these mesages

You need to format the disk in drive H: before you can use it

REPEATEDLY ever 10 seconds


(H: [drive letter] ) is not accessible
The volume does not contain a recognised file system.
Please make sure that all required system drivers are loaded and that the voluime is not corrupted.

File manager shows:-

(H) 1397.23 GB RAW
Healthy (Primary Partition)

Hello there,

Welcome to the WD Community.

As a recommendation, try contacting WD Support directly for this case.

Sound like the partition of your drive is corrupted.

You might be able to recover some files with a really good data recovery software.

WD Contact info:



Thanks for the response, however the drive doesn’t stay available long enough for any software to work. It constantly flickers on and off.

I have over 20 years experience building and working with  computers and have never encountered a problem with a drive, either internal or external but maybe I’ve been lucky.

I have no intention of ‘shooting the messenger’ but I also see no reason why I should pursue this matter wasting time and resources when the drive is obviously not up to scratch.  I’ve wasted more time than I care to already but would like to bring this to the attention of other people thinking about buying this drive.


I returned the drive to the store I bought it from and now have a replacement that so far works for two days.

Since changing the drive [which worked straight out of the box on my laptop] the USB socket that I plugged it into on my main computer works erratically for some devices ~ Coincidence ? ~ Cause?

The only downside of all this is the hours taken travelling to and from the store and wasted data, in total has been 7 hours + travel I estimate it at € 450 + loss of data. 

Sign of our modern technological times ?

I do praise WD support however as they at least took the time to contact m ref the problem.

Onwards and Upwards