WD Element 1TB not detecting but port is working


My WD Element is not working on my PC. The port is fine as i have tried and used other USB Flash Drives and that works perfectly fine. There is no issue with my Element as well because it is reading and working fine on other computer.

The PC i am using currently is old config and 2GB DDR2 RAM only, can that be an issue? Though it did work on same PC before.

Pls Help. It doesnt show on disk mgmt or dev mgmt too…


Have you tried replacing the USB cable? It is also possible the computer is not up to date. Try updating the drivers, specifically USB drivers.

Tried updating the USB drivers already…

The USB cable is definitely fine since it is working on all other systems.


I am having exact same problem with my Elements 1TB not working in my PC; works on my laptop and other USB works in my computer so not the drive. When I insert the cable, it makes a little noise like it recognizes it, but it doesn’t show up in File Explorer nor in device manager list (diskmgmt.svs method)>

I think the drive is not working because it is mapped to a different drive. Try this-

  • Click on My Computer and click Manage.
  • Click Disk Management
  • Select the WD Device and change the drive it is mapped to.
  • Check the windows explorer and My Computer.