WD Easystore mounts to My Cloud but not to MacBook

I have a WD Easystore 4 tb drive that I use to backup my WD My Cloud drive. When I plug the Easystore into the back of the My Cloud it will mount and I can run the USB Backup jobs I have created. Also, while connected to the My Cloud I can access the drive on my MacBook.

When I ejected the Easystore and tried to then connect via my MacBook USB the drive shows up in Disk Utility but will not mount. I ran First Aid and it came back ok but still it will not mount.

Any ideas?

This isn’t really a My Cloud issue rather most likely an issue with how the WD Easystore is formatted and or a failure of the Mac OS to “mount” or read the file system format of a USB drive. What is the file system of the USB drive? NTFS, ExFAT, HFS+, EXT4, other?

The following WD Support Knowledgebase article may have additional suggestions on how to ensure the Mac will mount and read a WD USB hard drive.

The issue is this is the 2nd backup disc that my MyCloud has somehow corrupted. I only use it to back up the MyCloud drive and do Time Machine backups on two computers. I can connect to the MyCloud and do the USB backups but when I try connecting it to either of the computers it won’t mount. I had a Seagate USB drive that I used to use to backup the MyCloud but it got to the point where even the MyCloud wouldn’t see it. I attached it to a Windows computer and was able to reformat, which made it mountable again. So you don’t think the MyCloud is causing the issue?