WD DX4000 - Dashboard no users/no network

Well got past the setup but now having more issues. Was running okay for a couple of days, then suddenly couldn’t login via dashboard on local PC’s. RDC to the DX4000 and opened the dashboard from there, it is showing no users. Server Manager is showing users however so not sure why they have dissapeared from the WD dashboard. Cannot add them in though as it still recogonises the names.

Also the box is now showing no drives, close to 2TB free in space (yet no drives?), and no network connection. WD Dashboard just says no information is available about the drives and that there is nothing connected via ethernet, which there is as it has always been connected.

So, I’ve updated dashboard and now I’m running 1000 windows updates and hopefully when I get to the end of that the problem will fix itself. Unless someone else has come across these issues before and can give some indication of what to do to fix it. Still haven’t been able to use this thing, over a week now and still just a paper weight.

Did you install anything on the server?  My vote is to do a recovery and start over

I haven’t been able to do anything. I had users setup, all connected fine. Then suddenly it decided there were no drives and no network connection. To me it looks like the WD software installed on the Sentinel is not communicating properly with the hardware. Despite it saying nothing is plugged in the ethernet ports work fine, the local PC’s can still see the shared folders.

The logging in issue is the fact that the WD software thinks there are no users, despite them being listed in Windows. Why it is saying there are no networks I’m not sure, and the drives are working fine. I just tried to create a new user via the dashboard after connecting remotely, which would be via the ethernet connection as I haven’t set up online remote access yet, and it didn’t like it. However I was able to do so via Server Manager. So to me it looks like to the software is buggered.

Why would an install of software cause interference between the device and the WD software?

The dashboard is real picky with dot net stuff and  IIS is picky about app pools.  Instaling stuff can break things.

You should look in services.msc and make sure all the windows server and WD stuff is started.

Windows server initialisation and windows server backup services are not running, neither is WD storage provider. Windows storage server is now current with updates, no more to install.

Is it possible to reinstall the dashboard without having to do a factory reset? I notice as well that the WD has always said there was only 2TB available when in fact there are 4TB (2 x 2TB). Will a factory reset fix this?

Those 2 windows not started is fine.  The WD should be running though that would not cause user not to show in the dashboard.  You should try to start it, then go to the event log and see if there is a usefull error.

There is no way to just reinsatll the dashboard.  2tb available is correct if you have two 2tb drives.  They are mirrored so everything that is on one is also on the other, thus 2tb available

Partially fixed some of the problems, figured if I am going to have to reset this thing back to factory settings I am going to have a play. Downloaded the latest sentinel software updated and unzipped the files. I ran EVERY WD windows installer package file, each one asked me if I would like to remove it. So I firstly removed it then ran it again to reinstall it.

Box no longer says no network connected and finds 2 drives. Connected remotely and checked the dashboard, monitor can see the drives and recognises the ethernet connection.

However, still having problems with the users. Dashboard doesn’t see them so thinks that there are none, just need to find how to fix that one problem and its all back under control.

When I try to create a user in Dashboard it comes up with an error and to try again later but if it doesn’t work to go have a look in the event viewer for the problem. Under event viewer where would I find the error?

let’s backup a minute :slight_smile:

You did not go into control panel >users and create a user as an admin and are logged in under that user now are you?

You can only remote to the server as Administrator.  Accounts created in CP do not show up in the dashboard and vice versa.  Accounts created in server manager do not show in Dashboard either.  Is the server logged on as administrator?

No, no, no. The users were only ever created via the dashboard. This whole thing was found out because all of a sudden I couldn’t login to the DX4000 dashboard using the administrator password on my local PC, I then tested logging in via Launchpad with a user name and password I had previously setup and that wouldn’t work either. However connecting remotely using the administrator login does work.

Within the DX4000 I can access the dashboard. The dashboard does not show any of the users I created nor does it show the administrator so it looks as though no users exist. This explains why I cannot login via dashboard using the administrator password or via launchpad using a user credentials that I had setup. According to dashboard there are no users.

But it does recognise that they exist as I tried to recreate a user in the dashboard, it knew it that the user was there. If I check the list of users under the server manager the users that I created via dashboard originally are there. So the problem to resolve is why won’t the dashboard software pick up the list of users that are on the server when they were created using the dashboard in the first place? What file/software is causing this glitch? And how can it be fixed? Is it part of the registry? Is there an error message I can find?

Its definitely the dashboard software that has gone a bit problematic. I’m just trying to find what needs to be adjusted to fix it. Must be somewhere as I’ve already managed to fix 2 of the other problems that looked pretty bad

You might look these over.  Windows Home Server v2 and SBS 2011 essentials are all the same dashboard.  Most all issues go back to services not starting.  Either Python, AV on the server, etc




Cheers, I’ll give each one a crack tomorrow morning. Doubt its anti-virus, I haven’t installed anything on the server yet. The user corruption sounds promising and a more likely solution so far. Fingers crossed, today hasn’t been a great day (aquarium sprung a leak at 2:30am this morning). Here’s hoping for a rebound in luck!

Hate it when that happens.

Tried the renaming of the folder, deleting the users then trying to add them via Dashboard. No good. I don’t think its a firewall/antivirus issue as it seems to be a problem specific to the Dashboard on the server. I’ve checked the services and everything is running except Windows Server Initiliazation Service, its set to automatic but isnt running. I set it to run but didn’t change anything, still couldnt add users.

I’m going to attemp removing the PC from the Dashboard then reinstalling the connector software. I’ve removed the connector software already but when I run it again I just get an error message when it asks for the administrator password. I’m not sure if this is because the Dashboard also has a problem with matching the PC’s on its records to what is recorded on the server. The deletion process is taking its time.

SO CLOSE! Fixed the user problem which was with the server certificate, found this link:


I skipped to this step:

  1. Type  cd “\Program Files\Windows Server\Bin”  and press ENTER.
  2. Type  WssPowerShell.exe , and then press ENTER.
  3. Type  Add-WssLocalMachineCert , and then press ENTER.
  4. Reboot the Destination Server

Then added the user via dashboard and it worked! But, tipping it doesn’t like the certificate from the network machines as it won’t let me install the Connector Software, just get an error message upon entering in the server password. So what would be the command line to import the certificate from the machines?

AND 100% FIXED, HUZZAH! Before I deleted all the files in the settingsproviderdata folder I copied it to the desktop. There was an xml document for each user as well as the server so I copied ONLY THE USER xml files back into the new settingsproviderdata folder then reset it. Connector software then began reinstalling, dashboard and launchpad now work, probably didn’t need to remove it in the first place.

So, my suggestion to fixing this in my case would be:

  1. Delete the users originally created via dashboard from within server manager.

  2. Copy the C:\programdata\microsoft\windows server\data\settingsproviderdata folder to the desktop.

  3. Leave the desktop copy, delete any files within the original.

  4. Reboot the server.

  5. Import the local machine certificate using powershell.

  6. Reboot the server.

  7. Check the desktop copy of serversettingsdata for xml files on the individual machines and copy them into the original.

  8. Reboot the server.

  9. Open dashboard and start adding the users back in.

Thanks for the help Gramps. So relieved that I did not have to reset it back to the factory settings. All I need today is for the aquarium manufacturer to say they’ll give me a replacement aquarium and for the warranty mob to say they’ll replace my broken Surface Pro 2 with a Surface Pro 3 and it’ll be a great day!

Sure you don’t want to reload it

Well glad you got it sorted.  One thing I should have mentioned sooner.  When you mentioned certs it made me think of it.

Check the date on the Server.  Sometimes it will get off on reboot and then weird stuff happens

for giggles look in c:\programdata\microsft\windows server\logs  dashboard

see if it had any cert errors