WD Drive Utility update v. to v. results in language change to Polish? Can not undo

After opening my WD Drive Utilities in order to change my password update v. was presented. I accepted. After installation and restart the language was changed into - what I believe - is Polish. I called support who advised to update the firmware which I did. Still Polish abacadabra. I had to re-install my original version to get my preferred language Dutch back. So I can not update to v. with model WDBZYL0020BSL-01. Anybody with the same experience and a good advice?


The application should install in the same language as your Operating System. You should be able to un-install and re-install the application even with your hard disk drive disconnected in order to isolate a package issue.

Same here. Dutch changes to Polish with update. Reinstalled new versions. Issued problemreport to WD. No reaction sofar.

Same here, Dutch to Polish after update. For no reason, my OS is definitely NOT set to Polish as I don’t understand the language.
Please WD, deal with this asap. Thanks.

WD-support acknowledged the problem and passed it on to a higher level. They told me tht this would be solved in the next update. It might take some time however. They told me to use the older version for the time being.

I know what you advised and this is not the solution. The problem was passed on to a higher level by the support department. That higher level told me that this would be solved with the nezt update. I should use the older version until then.

Having exact the same problem, I called WD support, and they told to have it exchanged at the store I bought it at.

But I see that won’t solve a thing.

I guess I will have to wait then till the new update, I can’t be bothered to translate the Polish sentences.

The software has been updated, working properly now in dutch!