WD Drive Ulitilities installer application does not opening in OS 10.14

I’ve downloaded the software from the WD website several times and it does ask if I want to open an application from the web. But after double-clicking on that nothing happens. I also tried in OS 10.13 with the same result. Need to change the My Book Pro drive to RAID 1

Version: WD_Utilities_Installer_for_Mac_2_1_1_80 3.dmg

Hi crispybrain,

Is the WD Drive Utilities installed in the computer properly and is it showing up in the application?

The downloaded installer volume shows up on my desktop. When you open that up you see the icon for the installer program which has a scewdriver and wrench crossed icon called “WD Drive Utilities Installer”. When I double click or open it, it animates opening but nothing happens

/Users/xxxxxxxxxxx/Downloads/WD_Utilities_Installer_for_Mac_2_1_1_80 3.dmg

Hi crispybrain,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support

The link below will allow you to call support.

OK I submitted trouble ticket.