WD does not see 'Windows Shares' Win 7 Prof

Despite reading the manual meticulously, and the myriad posts of what to set up, I still am unable to access shares via Ethernet after a coupla days.  I have worked in IT for decades so I’m not a totaly dumb newbie.  

WD can access web services through the LAN to the router.

WD connects successfully to the LAN, apparently - where can I see this from my Win 7 PC?

Should I instal Samba and try that? 

Do I need to run Windows Media Player?

Have fiddled with folder properties security for ever, seemingly.  They all include permissions for user “Everyone”. 

I have a coupla users show up with a red question mark and name consisting of long numbers:

"Account Unknown (S-143-873404 …blah blah .  'Could this be files created from  from a previous Win 7 instal - I keep my data on a seperate drive.

Use a WORKGROUP and can see all my network shares in Win File Exploder.

I know to reboot the WD (long press and hold to switch off).

I’ve yanked the inet cable out the router and turned off Windows Firewall, to see if that’s an issue - but naw…

Is there a methodical way to step through and work out what’s not connecting by elimination (or error log files?).

'Can only play media through local USB…



Thanks for any suggestions

Make sure you actually shared your media folders.

Set up a homegroup on your PC, the WDTV can access homegroups.

That’s how I did it and it was immediately able to access my folders.

Have you reviewed carefully the instructions on setting up shared folders in Windows 7

On Windown 7 Ultimate 20 steps

Step 1: Go to “Control Panel\All Control Panel Items\HomeGroup” 

Step 2: Select the check box against “Stream my pictures, music and videos to all devices on my home network”

Step 3:Click on “Save changes”

Step 4: Select a folder which has movies and songs to be played via WD

Step 5: Right click on the folder

Step 6: Go to “Sharing” tab

Step 7: Click on “Advanced Sharing”

Step 8: Select the check box against “Share this folder”

Step 9: Click on Apply and OK

Step10: Click on “Share”

Step11: Select “Homegroup” from the dropdown list

Step12: Click on “Add”

Step13: Click on “Share”

Step14: Go to “Security” tab

Step15: Click on “Edit”

Step16: Click on “Add”

Step17: Type “Everyone” in the box

Step18: Click on OK

Step19: Click on OK

Step20: Click on Close

Enjoy your movies now

I had several issues with getting the SMP to view files on a Windows 7 share. I know the shares were setup correctly as I could view them on several other devices (WIn7 box and iPad). I ended up using the Media Server capabilities within WIndows 7, but that has issues with certain file types (namely VIDEOT_TS folders). I ended up creating a NAS using FreeNAS. I will say that I never tried to get the Home Groups to work. I think I know what the issue might be with sharing over networks with the SMP and it has to do with the Samba client being used within the SMP. I saw these same issues at work using a Bufallo NAS and trying to connect to it using a Win XP machine. It ended up being a registry setting on the Windows machine that was set to use encrypted communication only. If the above answers don’t help you let me know and I will look up the Win 7 registry key that mandates Secure communications.

OK Guys - Thanks for the comments.  I tried all your suggestions that I haven’t already tried. 

Rien, Zilch, Nada, Zip!

Re: Arakon 

Yep.  I have a Homegroup and the network shares, (folders and files) have permissions for ‘Everyone’ to ‘Read’ plus me and Administrators.

Re: bpl521

Yes, of course.

Re: vizaik

Thanks for the detail.  However, I missed a step between 5 and 6 - re: after right-click does one select ‘Share’ from the drop-down menu, Or should I select menu item ‘Properties’ (after the right-click) and then click the ‘Sharing’ tab?  Because I could only see a sharing tab after ‘Properties’ and not ‘Share’?

Nevertheless, I went both routes and ensured folders and files showed ‘Homegroup’, ‘Everyone’, '{My Username} and ‘Administrators’ all having ‘Read’ sharing permissions.

Does the WDTVS need any more than ‘Read’ permissions?

Re: bbenz3

Thanks for your kind offer to “ look up the Win 7 registry key that mandates Secure communications…

I would be grateful for this information seeing as nothing’s working yet.

Re: Anyone

How can I confirm that my Win 7 machine ‘sees’ the WDTVS?

I see that in the WDTVS Setup option that the setting ‘Network share server’ is ‘On’ - haven’t seen that mentioned before, don’t think?  Is this correct?

Also, I heard that in ‘Contrrol Panel > ‘Network and Internet’ > ‘HomeGroup’ > ‘Share media with devices’ > ‘Stream my pictures, music, videos to all devices on my home network’  - someone said that this should be ‘Off’’ because the WDTVS is ‘pulling’ - not Win 7 ‘pushing’ the stream.  (I’ve tried it both ways though!)  Any comments?

Do WD staff monitor this forum to offer user / forum support?

Thanks in advance for any further help…


PS. Is there any auto-notification that lets you know when someone replies to a post on this forum?

The WDTV should show up under “Network” as a media player.

The WDTV actually needs write permission, as it has to create the database on the PC. However, this has no influence on wether the WDTV sees the shares or not.

I will look up the reg key tomorrow while at work.

However let’s troubleshoot to see if you have everything else setup correctly. Under the network section of the settings page you should see your ip address. From your windows PC open a command prompt (start - type cmd - hit enter). Type ping ‘ip address of wdtv box’ and hit enter. You should see four ping responses.

Also you can browse the wdtv live box from windows explorer by typing (\“ip address of wdtv”) into the address bar. This should connect but I don’t think it will show anything.

Now if the above works then we know that the windows box can see the wdtv box and that the wdtv box is on the network. To test the shares on e windows pc do the following. Open windows explorer and type (\“ip address of windows pc”) into the address bar. This should show you the shares that you have available.

As for the stream my … portion this is used when you want to create a media server on your windows pc. This will allow you to select the media server option from the wd tv box instead of windows shares. This however can cause issues if some of your file formats aren’t supported by windows media player. In order to have content show up you must setup your library inside of windows media player or windows media center.

I have since replaced my windows file server (spare windows computer) with a FreeNAS install. This alleviated my issues with sharing between windows and the wd tv box (due to samba issues).

Here is a technet article discussing the setting that I think could be causing your problem:


I think it could be any of the settIngs just above or below that setting. Basically I am thinking that there is a setting that requires traffic to be encrypted. As long as you are behind a firewall this setting isn’t really going to negatively affect anything.

Another setting that could prevent sharing to a Linux samba client is the lmcompatibility level. I would set this to 0 at first to see if this could be the cause of your problems. This settings limits the type of authentication that the windows machine will accept. I am not sure what types the samba client in the wd tv box is capable of using, but I have see this cause issues in my line of work between windows servers and Linux clients.

Good luck.

PS if you have a spare computer or if the computer you are using to share media is a dedicated computer just for file sharing then you may want to try and setup a NAS box.

Setting up the Windows shares can be a bit fiddly.  I was struggling until I followed this guide: 


The guide doesn’t show it but you need to complete a final step.

* Right-click on your share and choose “properties”

* Click the “Security” tab

* Click the “Advanced” button

* Click the “Owner” tab  … If the owner isn’t  set to “Administrators” you need to make sure it is

* Click “Edit”

* Click “other users or groups”

* Type in “Administrators” and click OK to everything.  Check that the owner is now administrators.

At this point I’d probably reboot the PC and WD TV box just to be sure.  Then go ahead and test.

What is your router switch SMP  connection tree?    Is the SMP and the Shares hooked directly into the same router?  Do you only have one router? 

That was my problem.  2 routers in the same network and the shares and SMP needed to be on the first ISP router. 

If you havn’t already, dumb down the  tree and just hook up your shares and your SMP into directly into one router and no switches or anything. 

Mine was hooked up into a second router that seemed to conflict with the ISP router.  I’d click on network shares and all it would do was spin the arrow… would never see it. 

I could also see the shares on all my comps just fine too… hope it helps

Thnx Arakon - you’re talking seeing the WDTV in MS Windows Exploder, under Network, here yep?  I don’t see it there…

Hi Mutt72, in the guide you post, when he choose the source of the videos, the WDTV Live SMP show the option “SMB/CIFS”, this means that this guy is using FreeNAS? I don´t see this option, I see “Windows Shares”.

I can’t see my windows shares on the WDTV SMP.

Thanks in advance.

I could only see “Windows Shares” on my SMP too.  I don’t think it really matters what you see at that point.  What seems to be important is how you configure the permissions and ownership of the shared folder.  

I’d be interested to know if the guide works for you.  

Yeah - Thnx Wazman - I’m getting dizzy from the spinin orange arra, too!.. ;-) 

Can someone tell us how long the orange arra whizzes before it finds a Windoze share  - so we don’t have to leave it for a half hour just to be sure… ? Hm?

No - I’ve just got the one Virgin Netgear 4-port Gigabit router to WD (Cat 3? whatever) and Win 7 PC  Dual Gigabit Ethernet with 4 hard disks (500+500  +  1+1) = 3 TB storage. No switches - just dummbed down deep as deep. 

I’m thinking of goin’  the NAS route now, anyways - I’m bored with this **bleep**! 

Any suggestions for a cheap (£30 - £90) dual-bay, empty NAS box + what O/S / server?

Thnx in advance

C’mon back…



I have followed the guide, then I’ve checked the owner, after that, reseted the PC, and the WD TV Live SMP. But I can’t see Windows Shares on the WD TV Live SMP. If I connect a usb flash drive to the WD TV Live SMP, I can see it from the PC. I tested the ping command, it’s Ok. I followed several guides, and nothing. My OS is Win 7 ultimate x64. I don’t know what to edit to make it work. Thanks for read this.

As for setting up WIn 7 to share I am not sure exactly why it isn’t working for you. I definitely had it working for a bit just ran into weird issues with it working then not and then working again so I jumped ship to a NAS (since I was using a dedicated PC anyways). As for what NAS OS to use I have really liked FreeNAS as it is really easy to use and setup. There are other more advanced distros but I don’t feel like tinkering that much these days. As for a what to buy in that price range I am not sure if there is a whole lot in that price range. I have used the Buffalo products and they are ok but nothing spectacular. Another option that is a 4bay is one of the HP Micro servers but they usually run around $300 or more. I had a case and PSU lying around so I bought a motherboard and ram and I am setting that up tonight.

My NAS Specs:

Asus E35M1-I                 $115

2x4GB Corsair DDR3     $40

Case/PSU (if needed)    $40

4GB Thumbdrive            $5

This would get you 6 HDD ports on the MB and be right at $200. I felt this was a major upgrade to what I had which only gave me 2 sata ports and was an old **bleep** that I just had lying around.

Hi bbenz

Thanks for your reply.

However, I’m not using domains - just a humble Homegroup.  So this doesnee apply - dowee?



There is a section for domains and a section for workgroups. So it could still apply.

Picked up a WD TV box yesterday and have spent the last 24 hours with the exact same problem.  Despite trying most everything listed here, I cannot get the WD to see the shares I have set up on my home server.  Every other machine on my network can see them just fine, the WD will only see things via the media center content option, not the Network Share option.