Wd dlna media server rescan

Hi everyone,

I have switched to the new WD dlna media server on my MyBookLive and I am very happy about it. Finally I can stream my mkv files to my Samsung TV. I like the thumbnails too.

However the rescan/rebuild functions do not work as well as I would expect.

Rescan (to show new content added to the drive) seems not to work at all. I ran it last night and this morning it was not showing any new content). Does it really need to take so many hours to find and index new files?

The rebuild function works better apparently. It ends up showing all media files (including freshly added content) but it does take a very long time too (several hours) and no media file is available during that process.

Is this normal? Is there anything I can do to speed up the process? Maybe specify what folder to rescan instead of a full rescan/rebuild.

What is the process used by the rescan/rebuild process? Does it have any kind of configuration file/options?

I see 2 processes running and eating most of the CPU :



Does someone know what they are?

Thanks and regards


Hello and welcome, how many Gigabytes of files do you have and where do you have them saved? Also check if you have the latest firmware version (02.42.03-027). 

I am having exactly the same problem with a MyBookLive (02.42.02-012)

I add media files and they do not appear.  The rescan is not doing anything and I end up having to do a rebuild of the database.

All shares are public and dlna enabled.

Any help gratefully appreciated.

Same problem here. Media files are not automatically added to the database, nor does ‘rescan’ do anything. Rebuild solves it, but A) takes a while B) files should be added automatically.

Still the same problem with the latest firmware, released some days ago.


I am having a similar problem. WD DLNA server was working fine till about a week back. From last one week it has stop updating new files. First I tried “rescan” which did not work. Then I tried “rebuild” and now it only scans media on default public folder and does not scan media files on any other folder (media share is enabled)  irrespective of whether they are public or private share.

Already tried disabling media share on folder and re-enabling and thereafter, rescan / rebuild. I have also tried stopping and starting DLNA server. Restarted MBL drive but issue is still there.

MBL firmware is  02.42.02-012.

Media Server Version is

I have the same problem when I try to see the new files added in my external HD (not USB connect) in the WD TV Play. Can’t find a option to rescan files, so I’ve plugged it off and turned it on again. The old files (deleted) keep there and the new one doesn’t show up.

I have this problem also and most recently when I rebuilt the database (*again* *sigh*) to research from scratch, it now no longer finds several of my folders at all.  So for example, in my Public share, I have a Shared Videos folder and within that I have 15 folders - one each for 1999, 2000, … 2013.  Each of those has subfolders for months with .mp4 files in them (family videos).  But the last couple of times I’ve rebuilt the twonky content db, it only shows 2006 and 2007 and only some of the folders and files within those are accessible.  

Help - all the family will be here Thursday and watching these is what the kids are looking forward to!