"WD Disk Utilities" gradually consumes all my RAM memory, and cannot see My Book Pro 12tb

Hoping for some expert help!

I have new 12tb My Book Pro cannot be seen by Mac. “WD disk utilities” runs away and consumes all the Mac RAM memory over several minutes. The drive shows up under thunderbolt in System Information, or under USB in System Information, but WD Disk Utility cannot see it when connect by USB; when connected by thunderbolt it reports RAID error, and says to connect by USB to fix (which does not work, of course). Tried it on two computers, and both Sierra and El Capitan. I have older My Book Pro that works perfectly on same machines/systems.


Have you tried uninstalling and reinstalling WD Drive Utilities directly from the WD website?

Hi, Yes, three times. Same result. Also, WD Drive Utilities picks up my older My Book Pro just fine. At this point I think this is a hardware problem, even though the drive is new (as of yesterday). When connected via thunderbolt WD Drive Utilities can see the My Book Pro, but says the drives are empty: Drive 1 Status Empty, Drive 2 Status Empty. There are drives in the slots. I also notice that the physical door on the left drive in the box protrudes slightly.