WD Discovery Service always asks for Admin password


#1

Hi there!
I have a PC running with an Admin User and a Standard User.
When the Standard User logs in, the WDDiscoveryService.exe always asks for an Admin password.
This was never the case before!
Of course I can change the user account to admin rights, but hopefully there is another way.
Be grateful for any help.
Kind regards
Richy


#2

#3

Thanks for the fast reply.
I will use the better solution of the two and also make the standard user an admin.
Thanks again.


#4

Well I thought I had the solution.
The second user has also admin rights now but still receives the message if WDDiscoveryService.exe is allowed to makes changes (ok, now without having to type a password in) but I, as the main admin never have that message…very strange!

Any other solution?
Is the desktop app WD Discovery actually necessary?


#5

It’s only necessary to access the Private User space of the My Cloud Home from Windows or macOS computer. Else you can use the Web Browser app or My Cloud Home mobile app for iOS and Android.
NOTE: The web app has an upload limit size of 5 GB


#6

I have decided that I need the WD Discovery to be able to synchronise my PC.
So I had re-installed the programm in the hope that this message (see earlier post) would not appear when starting up windows 10. The second user, as already mentioned, has also admin rights. There is now no need to put in an admin password anymore but now a “yes” or “no” is required.
I am afraid the solution given by the WDStaff is not acceptable. No way am I going to change the Microsoft Windows User Account Control (UAC) to the lowest setting to prevent the admin login prompt from occuring.
Any other solution please?
In the past, this was not a problem. It must have occured with some update.
Thanks in advance!


#7

The official solution from WD is the non admin user is not supported for WD Discovery.