WD Discovery Hangs System

I really have been attempting to make this thing work for over a week. Using a Mac, but can’t create a photos library file in the private area because WD Home Cloud doesn’t seem to support the extended permissions required. Tried to use sparse bundles, but slow as you can’t believe to use over (sure i can stream multiple video streams on my home LAN from my laptop, but attempt to mount a sparse bundle from the home cloud and things just crawl).

i tried just putting the raw image files in the private are but WD Discovery seems to hang the system every 5 minutes.

Is this product really just not ready for production? Is anyone having success with this product while using a Mac?

I am having some success storing all my pictures etc.

Seems to me that WD have some terminology wrong.

The private part is the one accessed from the internet so to me it is public (i know about the ‘private’ IP but not good enough.

Use the go feature on your make to connect to server do not enter a password just logon as guest and it becomes barely usable as an external hard drive.

Of course files you transfer to the Public area are not accessible from the internet.

No hair left to pull out.

I actually tried that for a while and it wasn’t usable for me. I had two issues with it. (1) every file has read/write/execute permissions for owner/user/group and the permissions could not be change which meant accidental deletion by family members was a risk and (2) every now and again it would just lose the connection for no apparent reason. Stability of connection has been an issue (and this morning the drive is reporting off line for some reason)


It is the only way I can get it to do anything even the discovery app tells me it does not support My Cloud home!

I will keep trying for a few more hours then if no success see if I can take it apart and at least use the hard drive in another case.

Connection not a problem it is just non existent it will not connect over the wifi!

I think I may be taking mine back as well. Very disappointed in the product at this point and have spent too much time attempting to get it to work. Not sure why building a NAS is so difficult for WD (I know this isn’t a true NAS, but I wish it was).