WD Discovery dont contains CBFS from Eldos Corporation (or dont install it)

Install WD Discovery for My Coud Home should be included Call Back File System (CBFS) from Eldos Corporation (answer.aspx?ID=20187)

I have a Windows 10, 64 bit

I installed previous version of WD Discovery (I dont know number of version), during installation I clicked on check box that I accept it and after this installation was all good - I could signed in WD My Cloud Home by WD Discovery (in Windows Explorer this device had a letter “Z:” as a single drive).

When I installed WD Discovery v2.1.332 (install file WD-Discovery-win-prod-ia32-2_1_332.exe) install picture showed the text that you must accept CBFS from Eldos Corporation, but not yet check box for click on accept this.

After install WD Discovery I did not find Eldos programme (in HDD and in registry).

WD Discovery have a grey sign in device after install .

Have an absence of CBFS on install a correlation with a grey sign in ?

Can I download and install CBFS of Eldos Corporation independently from installation of WD Discovery ?

Than you for help

1 Like

NO it is integrated with WD Discovery

Thank you 4 your answer, but how I to solve my problem, when during installing of WD Discovery I cannot accept CBFS ?

Thank you for your information.But I have tried my best to find the solution of this problem.
first,I installed the windows 8.1 in VMware virtual Machine.This one is clean,it has nothing but windows 8.1.
And then,I installed the WD discovery,During the installation,I saw the prompt box for the installation of EldoS Corperation like system device.
But I cannot find this prompt box during the installation of my PC(host of vmware),my PC has the same windows 8.1,and I have been working as a computer engineer for serval years.My PC doesn’t have a mess of software.
I find the installation and operation of logs from the "users/%user%/appdata/local/tmp,tried to find the call to EldoS failed error message,but did not find ,so can you tell me how you can see the error log,so that can try to fix it myself,thank you.
In addition, I also found the CBFS website,is it possible to tell which software can be installed.
I am not from the English speaking country,so if the post of desciption is not polite , please forgive me. Thank you.

@forgiveness Unfortunately, the My Cloud Home and WD Discovery is not tested, validated or supported on Virtual Environments, However, ensure Windows 8.1 has all the update applied and that you’ve installed WD Discovery for My Cloud Home v2.1 and not WD Discovery for DAS v1.3. Version 1.3 for DAS does not include the desktop app with CBFS

http://downloads.wdc.com/wdapp/WD_Discovery_2_1_332.zip

I am sure that my installation file is “WD-Discovery-win-prod-ia32-2_1_332.exe”.And I mean I couldn’t install CBFS on my PC,so I installed the WD discovery 2.1.332 on VMware to test it.
Thank you for your information.

@forgiveness please check Firewalls, Virus or Malware Protection, Internet Security or End Point Protection Software and rules. It’s possible something is blocking the Desktop App Installation process. Still failing, please open a case at support.wdc.com and provide the WD Discovery logs per the KBA below.

Hallo,

after install WD Discovery v 2.1.378 is problem solved, it´s working normally.

Thnx for all