WD Discovery and macOS 10.15.1 Catalina Support

Hi, hope someone can help. I have read various threads with regards WD not supporting WD Discovery and mac OS 10.15.1 Catalina Support. This seems rediculous. We are wedding photographers and chose this system to back up all our RAW photo files as they are huge in size. Obviously we cannot access them via the WD Discovery app on the Mac desktop and the only solution given is to use the browser based system. We use Lightroom and our RAW files on the My Cloud Home are linked. Obviously when we open Lightroom now it cannot link to these files. Other solutions are to download the files direct from the web based system but we have probably 1500 files per wedding and there does not appear to be a way of downloading a folder with all it’s contents. To download all the file individually would takes days.

Does anyone out there have any work-arounds as WD do not seem to be very helpful in coming up with a solution.

We put all out trust in WD when setting up this new system and as a result of not being able to use the Discovery app we have very angry client who understandabily want to see the wedding photographs and have no way of getting to them.

Could do with solutions/ideas for:

  1. When is the Discover app be ready to work with Catalina?
  2. A solution to download a whole folder from the web based version?
  3. Map the drive?
  4. Lastly, is it possible to remove the hard drive and fit it in some sort of enclosure to enable it to work via USB?

Any ideas would be great as we are at the end of our tether with this one and no help from WD.

Regards Paul Walker

Hi,
Which version are you running?
3.5.152 is supposed to work with Catalina. (We all were very angry at WD and still are)

Best

We are running 3.4.89 this was downloaded yesterday so asume it was the latest version?

Regards Paul

Weird.
Only 3.5.x will run on Catalina. But it should have updated itself.
Where did you get the installer from?
Try my link anyway.

Thought it was from WD site, I’ll try your link, Thank you

Hi Bud, tried the link, downloads fine. during install it hangs at 66% and goes no further.

:frowning:
You are not alone then: WD Discovery 3.4.89 and macOS 10.15 Catalina Support

I have the same issue. It installs to 66%, then the icons disappear and nothing happens. Tried multiple times. I uninstalled and rebooted as per the suggestion. Deleted all WD files. I can’t think what else to try. Very poor from WD.

I finally got it to install and now all works as it should, too quite a few attempts before it installed and took a long time to do so, still hung at 66% for about an hour then all went through. It’s important to use an app such as ‘App Cleaner & Uninstaller’ this deletes all background files that appeared to be one of the main culprits.

@ Paul-pwp Good advice, thanks. When it hung at 66%, did the icons in the dock disappear? On mine it just seems to decide against installing and go back to the start.

The icon changed every minute or so and continued to do this untill it decided to finish installing.

It was worth a try, and $10 for the uninstaller. No use though, it just disappears at 66%. Also from the Activity Monitor.

WD Community,

If you are having issues installing WD Discovery on macOS, it may be failing due to macOS permissions.
Please uninstall and remove WD Discovery, reboot and install WD Discovery as the macOS root user
The instructions are included in the KBA listed below which also includes a link to Apple Support: How to enable the root user on your Mac or change your root password

WD Discovery Fails to Install on macOS
https://support-en.wd.com/app/answers/detail/a_id/28936

Thanks. Tried all of those steps exactly as written. Twice. No luck.