WD Discovery 3.4.89 and macOS 10.15 Catalina Support

Hi there, hope everyone is good.

I have a question for the WDStaff, I have had a WD cloud mirror and have been using it for my business files which has been great. I have now updated my Mac to Catalina 10.15 and it’s stopped giving me access to the cloud now!

I can see from the above it’s not just me so I am asking “do you have a fix for this”??

I can connect via my PC and phone fine.

I managed to find WD Sync Settings - which I installed and it seems to talk to the cloud but only allows me to sync files from the laptop - not give me access to the files already on the WD Mirror.

I see you keep posting links to the WD discovery above as a solution (which works for the “home”) but I need a solution that works with the old school WD Mirror!

Can you help??

Cheers, Chris

i can’t even access anything on a window pc

Ok, little update after 300 attempts!

With Mac to Catalina 10.15, I managed to access the files from the Mac!!!

I’m not sure if I just missed this as it seems simple, little embarrassing how easy! (tho no thanks to WD!)

Open finder - go - connect to server
(here I popped in the IPv4 IP address found in the settings of the control panel of the cloud)
Shows in the location finder now :)))))

Never been so happy! what a total joke of support! ■■■■ that Catalina update!!

Never buying one of these again, once it needs changed I’m heading as far away from WD as I can!

Good luck everyone else!

1 Like

Markosftm, it was a while ago I set the PC up (couple of years) but I think I just followed this video and it worked a treat!

Hope it helps :slight_smile:

Well that must be the public shares not the private user space, for that you need that discovery app.

Yeah. Disappointing.

Hey,
Can you please explain this in more detail?
Going round in circles with this product. Trying to log in to the network but it won’t accept any of my log ins. None of the downloads are working for the software.
Losing the will…

2 Likes

Following this thread as mine was stuck at 50%. @sankovich17, can you explain more how to find the IP address. Thank you!

Well I’m glad to hear that the mobile apps work - awesome so let me hold up my mobile to my iMac and see if by some osmosis it will transfer and sync the files from my iMac to mycloud.
I found that after upgrade to Catalina, WD Discovery was interfering with my automated daily backups - I had to start the back up myself or I would keep getting backup failed. After I uninstalled WD, no issues at all. I mean I can’t include the issue that Mycloud home was inaccessible except by Safari or Chrome. Anyway, I did get a message from Apple that WD was considered legacy software due to some extension that would no longer work and to contact the app developer to fix it.
I mentioned in another thread as I’m trying to find a solution for iMac and Mycloud Home that I got the error message that there was a server problem and to check my internet connection and try again.

I do hope WD support sees this thread and fixes whatever the extension glitch Apple is talking about

I tried this and got the message I had a newer version. and the newer version wasn’t working and thought heck, I’ll uninstall the newer version, install the full version
and nope didn’t work- still says network error check internet and try again. So i updated again to latest version - using the internet and same old same doesn’t work and check the internet LOL

Thanks for sharing the information
vmware

Thanks for the information sharing
vmware

@wirywrestler The error message may be different per version but the “internet” message normally indicates a network DNS, Firewall or Blocking issues.

Answer ID 19715 WD Discovery Message “No Internet Connection”

@SBrown Hi,
thank you for getting back to me.
WD Discovery installs ok and I see MyPassport, which I use for local backups. However, when I click on the link to log into MyCloud Home, that’s where I get the error, server is having troubles and to check my internet connection and try again.
From what I can see in my home network, all devices are connected. I’ve given KDD full disc access rights, I’ve checked BitDefender in application processes to make sure it’s not blocking anything and WD is allowed.
I did have another issue where I believe it was the Desktop app was interfering with my automated backups. There was almost a whole week of backup failures (I backup daily). I had to manually perform a backup. After I uninstalled WD Discovery, haven’t had a backup failure for the last few days. Could be coincidence, I don’t know.
Is there anything I missed? if so please let me know.
Also, when I restarted my iMac after a recent update, I got the message that the extension for WD Discovery was considered legacy and would not be working with further updates and to contact the app developer for an update.
I look forward to hearing from you with any other suggestions or tips.
I have no issues with WD Discovery on my pc, My Cloud Home works well on my pc and mobile devices.

And for the time being, I have uninstalled WD Discovery on my iMac

@SBrown I think I may have found what’s causing the app from not working.

I use Acronis for my backup and I just noticed a couple of notifications from Acronis’s Active protection. Both were notifications that Active Protection was blocking kdd.

One notification says The process was blocked: /Library/Application support/WDDesktop.App/contents/resources/kdd
The other is: This application was blacklisted: /Library/Application support/WDDesktop.App/contents/resources/kdd

Since WD partners with Acronis, can you find out why Acronis thinks kdd is bad?
What is kdd?
Is there a work around that you know of?

Meanwhile, I think I will send off a note to Acronis too
Thanks