Wd Desktop App not working - Mac OSx

Hello everyone!
I do know that the WD Desktop App has been shut down by WD but it was simply the best way to use and manage files when I’m not home. It was simple and easy to edit files such as texts, presentations or anything like that, as I would not have to download the file and then upload it back later.

The app was working properly until the end of October but it does not seem to work anymore (I have tried downgrading the firmware but it did not work). Is there a way to use it again or maybe another alternative besides using the lame website provided by WD?

When at home the afp connection is way too slow (via wifi - NAS connected through Gigabit). When I try to save files system almost crashes down every single time and save and transfer times are way too high.

Also tried connecting through e-mail or security code, none of them worked.

Cannot use Sync App as I don’t have enough spare space to waste on my laptop, with files I don’t use that often.

And no, it’s not an old laptop, nor it’s a “weak” one…

Thank You. Hope someone does know how to make WD Desktop Working again.