WD Desktop App fails to install (Windows)

I am getting the message 'The WD My Cloud desktop app failed to install. Please contact WD customer support.

Anyone else had this and what is the resolution?

(by the way, i have checked and it has not already been installed, so cannot delete and re-install)


Try to download the latest version of the app from our website.


I’m having the same problem I tried the link and it still did not work. THis is a big problem please help !!!

Same problem here and with several others

To all having this installer problem,

I would like to know a few things about your system:

  • which OS version you are using (ex. Windows 7 Pro 64bit)
  • which WD My Cloud Desktop you were using prior to upgrading

This will help us identify and locate where the issue is.


This has become a real issue for me. I’m using Windows 7 (64-bit).

Not only will WD My Cloud Desktop App not udate, but I can’t even uninstall the previous version to try a new install.

I’ve physically deleted the old version off my hard drive and physically cleaned up the registry, and still the latest version of WD My Cloud Destop App will not install.

After accepting the two licence agreements, it tries to install and stops to return a message of:

“The WD My Cloud desktop app failed to install. Please contact WD customer support.”

Does anyone have a solution for this problem? I’ve looked everywhere with no success.

This is becoming very frustrating.

Found a solution that worked for me 100%.

Please read 5th post by Reny72 in following thread and give him some positive kudos if the solution also works for you.


I’ve been trying this but did not progress. I also tried the fix mentioned by Reny72 (uninstall using “registry cleaner” Microsoft fix) but this also did not help.

I’d be very grateful for any assistance.

Windows 7 Enterprise SP1