Wd Dashboard no longer working

Hi, my Wd Dashboard is no longer working (Black Shortcut on the desk top). When I click on it it says “Page Can not be loaded.”

I did recently set up a wifi range extender and I’m assuming that has something to do with this problem. Can you direct me on how to resolve this issue? I filed a support case with WD last week but have yet to hear back. I did however get a response to a support case I filed back in novemeber. So if you think nobody is on the wd support team fear not. They are there. Just don’t expect a reply in under 3 months!

Thank you wd community,
Xbox one sweetcorn15

Hi Ryan,

I think you must first check couple to things:
1- What is the the color of the front LED of your device?
2- Are you able to access your data via other mediums (like your laptop, mobile etc)?
3- is the Ethernet cable connected to your device? is it blinking?

these are all to make sure that your device is connected to the netwrok.
Please check and feedback.

Hello Amir,

I am still able to access my data from my phone and my computer,
Blue light is on. Everything is working fine. Except for “My Dashboard”

Just to be clear like I said everything is working as far as accessing my data. But when I click the my dashboard icon my browser pops up and is unable to load the page. It tries to connect to an IP but the IP cannot be found. I’m wondering if I have to run the set up process again or something.

I am trying to access the Dashboard for the first time. Entering “admin” leaving the password empty did not help.
Reset (twice) did not help. Hotline had no idea.
Technical support is not accessible. I tried now about 15 (!!) times.

I can see the folders and upload and read files. But I have no control over my device. My guess is that it is not working with Apple Macbook etc.

Is the only way out returning the product? The support is really terrible!

If the WDMyCloud was set up using DHCP then it is likely that your IP address for the WDMyCloud has changed. Run setup again.

Or, download Advanced IP Scanner and run that to find out what the IP address is. Then you can edit the shortcut to change the IP in that shortcut.

BTW, this is one of the reasons I only use fixed IP addresses for permanent devices on my LANs.


I use a MacBook. I’m pretty sure the login/pass is your email address and password you chose during setup.

I can logon to the files through a browser using email and password. But not the dashboard.

Also a reset should allow to use “admin” and no password to logon to the dashboard. But unfortunately, that is not working either.

I tried also with my email and password. But that does not give me access to the dashboard either.

I’d tell you to try wd support but they are pretty much non existent.

Very true! I will wait a few more days and if nothing happens return the product.

Not your email address, no. Local user accounts (and you can only access the Dashboard locally) are single names; your first name if you entered a given name and family name. e.g.

joe user

would be given a MyCloud local user name ‘joe’.

Email addresses are used for remote access via mycloud.com

Have you checked Chapter 6 of the user manual?

And the password?

Access (to folders) through mycloud.com works.

I tried it as you described but still no access to the dashboard.
And again. After reset it should be “admin” which also did not work.

I did read he chapter 6 up and down.
I do get the to fields to type in user and password. But it does not work.
Not on Safari, not on Chrome, not on Firefox.

This reply is for Ryan_Wolfram who started this discussion.

If you are using a Windows PC right click on the shortcut choose Properties then look for URL under Web Document tab. Place this in your browser and see what happens.

If the above does not work go to the Control Panel>Hardware and Sound>Devices and Printers, if your My Cloud is showing do the same thing, right click on it choose Properties then UPnP and check what it says the URL is.


I am using a MacBook Pro.

After a 4 second reset, the administrator’s password is cleared, but the administrator’s name is not, I don’t think. So it ought to be the first name of the administrator.

System factory restore (40 second reset) clears users, and thus returns the administrator name to ‘admin’, with no password.

Thank you. Tried the system factory reset.
But it did not work either unfortunately.

Try closing the browser tab, or clearing the cache; I think I’ve seen ‘phantom dashboards’, operating from the cache, when the cloud isn’t yet responding.

Then use the IP address of your mycloud in your browser’s address window:

http://<IP address>.local

I looked up the IP address in my DHCP client table of my router. But I cannot access the device with that IP address.
Cleaning the cache also did not help.

Did you re-boot the router?


Many times now and again this morning.
I think I waisted of my time (and time of many supportive people in this community). I will wait if WD ever contacts me until the end of this week and otherwise ship it back.