WD Cloud Not Saving File Changes After Your Last Update

When I save files on my Samsung Note 4, WD MyCloud saves the changes but when I check back later all my changes are removed. I have tried opening files directly from within the WD MyCloud app and I have tried using the WD Auto Sync function which updates my local files. No matter how I attempt to update my files all my changes are made but later removed. In two years I have never had this problem until your last update. The sole purpose of my WD MyCloud is to store and save changes to my files and it fails to do that. It is unheard of that this is even happening. What is going on?

Example of what just happened:

I saved changes to a local WD MyCloud Auto Synced excel file stored in my internal storage on my Note 4. The changes saved just fine. I opened my WD MyCloud android app and checked to see that the changes were made on my WD MyCloud hardrive and confirmed that the changes were in fact made. A few minutes later I opened the local file stored in my phone again and all my changes were removed. I then checked the file on my WD MyCloud hardrive and all my changes were also removed from that copy as well. How in the world can this happen? I never noticed this problem before your last update. This is utterly ridiculous. What did you do and when is this going to be fixed? All of my WD hardware and software is utterly useless and unusable right now.

I have already tried rebooting, reinstalling all software, etc. Nothing helps. Your last update seems to have caused all  these issues. When will this be fixed?


Thank you for reporting the issue to the WD Community.

Have you opened a support case with us?

If not, please open a support case with us and attach the system logs from your My Cloud NAS.

It would also help to know if you’re accesing a public or private share.


Samuel Brown