WD Cloud EX2 "Offline"


I’ve got an issue with my EX2. It keeps going offline. If I switch it off and back on again it works fine for a while. This is a bad enough when I’m at home, but of course when I’m away I just can’t switch it off and on again.

The main use for the EX2 at the moment if for my daughter (doing her Masters) to save and recall information (which she is obviously finding difficult to do).

I’m running the latest firmware.

Is there anything I can do to keep the EX2 on-line?

I’ve got the same issue… Really starting to annoy me immensely.

I have just had the unit replaced and have carried out all firmware updates. I have put 2 new WD Reds in for 6 TB and have started moving my data across from my portable drive back on to the unit. I have a drag and drop window showing the data moving across my own home network and it stopped at 70% and cannot access the WD EX2 drive anymore!!!

I cannot access the dashboard and I cannot access it from any other device (iPhone/iPad/external network). I have done a hard reset of the router to rectify, but nothing works. The only thing I can do and have done in the past to make it work is a 240 V reset on the device. This is not good for the drives, but without doing this it will stay offline.

There is no common action that seems to prompt the device to go ‘Offline’, sometimes it will work for a while before it does it and sometimes it’s pretty quickly offline. It’s a ridiculous situation!!!

Could it be possible that your router or switch port has a so called Green Energy mode that causes the port to switch from Gigabit to Fast Ethernet? We had this several times with Fritz!Box routers and their energy saving settings enabled by default. If this happens, the connection is lost as no NIC will react on this.

I have same issue too.

Ping -t is not costant, ms are always the same, sametime it stops respondig for no reasons, i suggest to reload old firmware 1.xx.xx, you will lose Cloud access but rest work good.

Till WD will not fix it, is useless upgrade it. btw i’ve opened case at WD, no answare or answare with pre-compiled e-mail.

best would be to activate the enhanced loggin and then talk to the WD Support, I don’t think that this is a firmware issue as this type of claim is very rare regarding the amount of installed EX2 out there.

Then… why if i install the old firmware all problems disappear ?

@ Hidden_Mickey and @ Simone_Z

Best is to contact WD Support. The issues with dropped network packages can be caused by a thousand things. WD Supports even helps to activate the enhanced login of the protocols so that there is a good logfile of the operating system which can be used to identify possible issues.

@Joerg_A WD support is useless and the telephons italian numbers aren’t reachable from any telephone line.

i’ve renunced to contact them, i’ve opened 3 case = 3 case closed with a simply pre-compiled e-mail that explain how reset the device.
I’ve no network issue, all my devices on my network works fine, only the NAS has that problem.

Solution: swap it with a serious devices (NO WD ofcourse)

i have to reset my nas every 2 days or is no more accessible…

I’ve tried to set up a case but it won’t accept my Model number. I’ve tried every combination of Uppercase/Lowercase/spaces / no spaces etc but I still get the error message to input my model number. I tried using my serial number but it still asked for a model number.

Managed to raise a case. Seems I have a “feature” on my iMac. Used my PC and logged everything on that without issues.

Now to see what the resolution is. Fingers crossed.

Hello, I bought My Cloud EX2 8Tb ten days ago and all this time I try to understand what’s wrong. This device can sleep and nothing except hard reboot (turn off power and then tour it on) helps me. I have router Zyxel NBG460EE and MacBook Pro. Could you help me, because I’m on the verge - I’m really want to return the device. It costs 580 USD and works badly.

OK. I received the following from the WD support site:

  1. Open a web browser and access your My Cloud Dashboard
  2. Select the “question mark” icon in the upper right hand corner of the dashboard to expose the drop down menu
  3. Click “Support”.

I have done as they have asked. Anybody enlighten me on what may happen now. (Averaging 3 re-boots a day; methinks I may have bought the wrong NAS manufacturer).

December 1st: Still no joy from customer services. Still having to re-boot 3 times a day. I was always a great fan of WD but I’m afraid I don’t think they are reliable NAS manufacturers. Sadly, it looks like this unit is going onto eBay and I’ll source something more reliable. It’s cost me money, but we all learn by our mistakes.

Did you get yours sorted?

Hi guys, unfortunately I have the same problem. I am using Apple Mac. My WD device stopped working properly on one day. Until now it is not able to be recongnized in my home network when connected via WIFI. In this case I can access the dashboard only (via IP address) and mobile/desktop My Coud application. No chance to map it as other disc in Finder.

Device fully discovered in network only when I connect my Apple Mac directly to router via Ethernet cable.

Does anybody know why it is not working on WIFI now? Can it be because there is no current WD support of Apple XOS 10.11.?