WD Caviar black problems? - Please help!


#1

Hi all,

I’ve some weird things happening on my computer and I hope you can help me sort out things.

I’ve a fairly new computer with Windows 7 ultimate X64 and a WD1001 Caviar black hard drive.

I’ve had issues installing applications or drivers in the past (it was taking litteraly hours) but nothing really bad.

About 3 weeks ago my Windows update stopped working (it stays at 0%) and I couldn’t update MS security essentials either.

I can’t stop some services (like Win update) because of "“access denied” even though I do it as admin.

I tried to install WD’s Data Lifeguard diagnostic (I know it doesn’t seem to be available for Win 7) but when I run it, it says I don’t have any physical drive (but it sees the logical drives!)

Today I can’t even start WinDLG!

I tried to install HD Tune Pro (for Win7) but I can’t install it (it says “Unable to execute file in Temporary directory. Setup aborted. Error 5: Access is denied”)

What’s going on?

Do you think it is a hard drive issue? a Windows 7 issue? A RAM issue?

Thanks in advance for your help!

A


#2

Win Dlg doesn’t work on 7 yet.  The rest you’re experiencing could be any number of things, including a virus.  Do a virus scan, then run windows scandisk and error checking, then make sure it’s defragged.  Once those are out of the way, then you can start with hardware.  You may need to get some personal help for this though.  If you know someone who knows computers get them to sit down with you and look at it.