WD Blue restarts with any internal powersupply

Just got this WD40EZAZ (4TB). With four different desktop powersupplies I’ve tried, it will randomly restart/respin every once in a while, but mostly when I try to access it.

It won’t show the same problem if I connect it in an external Seagate FreeAgent disk enclosure using a seperate power adapter.

All other 4 supplies I’ve tried work great with all my other 5 hard drives, and the WD would fail with any of them even if it’s the only HD connected. Here are the supplies:

WD Data Lifeguard didn’t report any error.

Does the WD40EZAZ require a special powersupply? is it defective?

Hi @system100m,

Please refer below link to contact support team help you with best possible way:
https://support-en.wd.com/app/utils/login_form

Is this noise that the WD makes, normal?

I ended up returning my WD to the store and replaced with a Seagate Barracuda. Never in my life I came across a situation in which 2 new HDD were DOA! I also found talking to WD support that intl. warranty isn’t respected if purchased in certain countries. I’ll never ever buy WD again.