WD Blue 1TB Win10 Installation Media Couldn't Find Drive - Need Driver

  • Attempting to install Win10 via Windows Installation Media on WD Blue 1TB.
  • The Installation Media couldn’t find any drives.
  • I can’t find proper driver for the WD Blue 1TB.
  • Two Days working on this and no joy.
    Details below.
    Thanks for any help.

1 - Old hard drive crashed
2 - Downloaded Windows 10 Installation Media on another PC
3 - Installed it on a USB drive
4 - Via SCSI adapter I plugged the WD Blue into the working PC and created one single partition named “OS”

5 - Pulled all drives from problem PC
6 - In bios I setup problem PC to boot from USB
7 - The PC boots up fine with Linux Mint USB & sees the WD Blue Drive and I can create a text file on it.

8 - I connected the WD Blue to the problem PC
8a - I then plugged the Win10 installation media USB into the problem PC and turned it on.
9 - Next I navigated through the Win10 Installation media screens

10 Clicked “I don’t have a product key”
11 - Chose Win 10 as the OS to install
12 - Accepted terms & chose Custom Install
13 - Next Screen says…
"Couldn’t find any drives.

14 - I downloaded Intel RTS Drivers…
… f6flpy-x64 and RST_V19.1.0.1001_PV
Neither worked.

Thanks for any help on this problem.

1 Like

Hi @Fran_3,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

Hi, any luck there? I am having the same issue with WD Blue SN570 NVMe SSD with asrock. Linux sees it fine, bios sees it fine, windows does not see any drives.

It works now. I used Rufus to prepare Windows 11 installation USB. It did a few tricks: stripped TMP, CMS and something else. So clearly one of these helped. After that the installation progressed smoothly.