WD Black2 Dual Drive & Windows 10

inVidiaWeTrust! :stuck_out_tongue_closed_eyes: That’s terrible as a variable name. But it might serve well as a nickname for some Nvidia fanboy out there.

Yes, I get it. But can you break this “rule”? Can you have an old 500 GB HDD cloned as is, onto the WD Black2? It seems silly that you have to obey by this rule. I am under impression that this “rule” is only a recommendation, as a way to get the best performance. See my previous reply in that regard.

What I mean is something like this.

Old HDD: 500 GB
WD Black2: 120 GB SSD + 880 GB (?) HDD

Then have the 500 GB cloned to Black2 in a way that it spans across the 120 GB limit into the HDD portion of it.

Maybe this can’t be done? And you must keep it inside the 120 GB boundary? I don’t know. It would seem like a terrible piece of engineering junk to me. The very first thing of having to use a specialty software tool, and of all things proprietary software and no longer supported… just in order to make use of the product… that makes me puke!

I’m sure it’s a good performing drive, and with plenty of capacity too. If you can get it to work that is… and that’s the thing, is it not? It can be super cool and awesome and good performing and all that… but what good is it if you can’t use it?

But I understand better now why you could not or should not have borrowed the 256 GB Samsung and cloned that one onto this one. See what I meant by complicating things? One problem leads to another, it escalates, unless the initial root of the problem is resolved. Your Toshiba HDD of 465 GB can’t be cloned for the same reason. Not onto the WD Black2 anyway. Or not without doing some manual partitioning and cloning and stuff.

I’m afraid this is just a very expensive 110 GB drive!

I only cloned to Samsung SSD as I could not get the WD SSD to clone at all. In hindsight I should have just bought a 500 gb SSD and then when my 2nd 500 gb HD filled up - if that would even happen and then buy a 1000 gb HDD for 2nd drive and I would have saved a week of my life.

Well, I hope you have learned something from this “experience” if you know what I mean. We all make mistakes sometimes.

The very first thing that’s wrong with this drive is the fact that they force it on the user to keep track of how big partitions they make on the drive and how big partitions they clone from their old drive, just because of the internal composition of SSD+HHD inside the WD Black2. The drive should do these things all by its own if you ask me. The user should only see one big, fat (no pun intended) drive in Disk Management.

This is not really a hybrid! Not when the SSD and HDD parts of it are so badly integrated. They really function as two physically separate drives. Also, it’s software dependent! I saw in the video that the WD installation software has to be left in place after completing a successful installation. I assume the link between the two parts of it, the SSD and HDD are broken when the user uninstalls the WD software inside Windows. This should have been implemented at hardware level. That way there would be no fuss. The SSD should work like disk caching. That’s what I would consider a true hybrid drive.

The second thing that’s wrong is that the WD software is no longer supported, and it’s not open sourced. If the WD software can be replaced by a few command lines or scripts, then WD should post those on the website. That way we could make it work with or without support from WD and without the original software. Either that or they should release the source code so we can help ourselves when they won’t.

Just out of curiosity, have you tried DISKPART? Do you see the HDD portion of it? Also, did you disable SECURE BOOT in your system BIOS?

You might be able to pull something off using Windows 7, a VM, and a hypervisor. That is if you cannot afford (don’t have time for) a clean installation. Besides, clean installation might not be possible after all. If the so much needed specialty WD software is needed for the SSD+HDD to interconnect, and it’s no longer supported and doesn’t work under Windows 10. In that case it may only work if you do a clean installation of Windows 7 and then upgrade to Windows 10.

I doubt that the SSD and HDD interconnect at all… they appear to function as two completely separate drives. So what’s the benefit of this solution anyway? Two physical drives bundled in one black box, at an affordable low price? I don’t mean to mock WD but this is just… I will just stop it here.

I would really like to help you with this. But I’m not sure what can be done with so many limitations and caveats. Software is not working, disk is not showing… there are no commands or scripts available that can do the same, and no documentation about these details. Well, let me know if you have disabled Secure Boot and if you can see the HDD in Diskpart.

Latest update on this loooong thread. Just got off the phone with WD support and they are sending me a new drive, same as the one I have. They offered a couple of replacements but were not as fast as this drive. I thought I would try another as I do like the features this drive has if I can get it installed properly. Win 10 not being compatible was never brought up. Thanks all and will post when new drive arrives and I continue this saga.

Ok so here is the Black² on MY laptop and Win 10 installed without the use of the WD Black² Installation software.

This is what I was trying to explain, you don’t HAVE to use it for Win 10 IF you setup your FIRST partition on the drive as EXACTLY 111GB using Acronis. Only reason I say Acronis is because you can use 111 as the partition size and you’ll end up with 111.8. Where with Disk Management you’ll have to do some math to get there (111.8). If the first partition is larger than this it will lap over to the platters (I think) and therefore cause a performance hit, or worse. THEN you install Win 10 via a clone. You MIGHT be able to do a fresh install I haven’t tried it yet. You may have a boot issue the first time you boot it up. I shoved the Windows 10 install DVD in the drive and ran the trouble shooter for boot issues and it got fixed and it’s been working great since mid December 2014. Now, you have win 10 running. Pretty sure my next move was to set the partition for the D: drive to the max size DRIVE MANAGEMENT would allow (default settings).

You might have success if you install Win 7, then upgrade to Win 10 but I think I read somewhere the WD Black² software mucked that idea up. I had also read that someone used 97GB instead of what I used (111GB). I don’t know which size would be better and maybe I have run over on to the platters and this might be the reason for my boot issue.

Disk 0 is the Black²

Thanks flhthemi, there are a lot of these drives out there so I’m sure mine was a bad drive and when I get a new 1 it will be fine. I will let you know, thanks for your help and input.
Andy

OK, so the SSD part is exactly 120 GB, and the HDD part is exactly 1 TB. Correct? Those should be the normal, base 10 prefixes if they are printed on the drive label. So if you convert it to binary prefixes that’s:

SSD: 114,44091796875 GB or 117187,5 MB
HDD: 953,67431640625 GB or 976562,5 MB

Rounding to the nearest units:
SSD: 114 GB or 117188 MB
HDD: 954 GB or 976563 MB

So from the looks of it, you are utilizing the SSD part if your partition is 111 GB. So as your first partition starts at the beginning, you can’t have stretched it to the platters (I doubt that it’s even possible with this kind of drive design). You still have about 3 GB to go to the right on that diagram before your hit the SSD/HDD threshold.

If it’s really that important to keep the size of the first partition partition down, then you can easily create that with either tool, either Acronis Disk Director or Disk Management in Windows. Note that the threshold is at 114 GB. For your convenience you can use the numbers above, and use the MB sizes inside Disk Management as it only accepts those.

Here’s what you type into the dialog box inside Disk Management:

And here is the result:

The volume creation dialog box is easy to understand in Disk Management. It’s the dialog box for shrinking or extending partitions and volumes that are often viewed as complicated. I understand the frustration. I too hate Disk Management for this, it’s unnecessarily unintuitive… but that’s what Microsoft is providing us, so we better get used to it. They have not felt the need to update this tool since they acquired it from Veritas Software Corporation. They just bumped up the version number for this in Windows 10, but it’s the same old tool.

Well… you’re not really installing it when you clone it from the old HDD. :slightly_smiling: But historically speaking, you’re actually right. That’s how it was done in the old days. Just a simple copy operation, then you execute the program. I remember the time when you just had to push in a diskette to install a program! Haha! :joy: Those were the times of computer greatness! These dumb installation “wizards” and registry configurations and stuff like that are just stupefying the general public and computer users.

So yeah… you’re both right and wrong. Right in the historical sense, but wrong in the current state of things. For a “install via clone” to work properly, you must make sure to clone everything! Every byte on that drive counts! So… did you or did you not clone the boot sector? Because if you failed to clone the boot sectors as well, then you expressly asked for it not to be bootable. You must clone the boot sector if you want the system to be able to boot off of the cloned drive. If you used the Windows DVD installation disc to repair it for you, then it has created a new boot sector for you on the cloned drive.

There is an option inside Acronis True Image to clone the boot sector. This option is normally hidden. There should be an option, something that looks like a blue hyperlink, on which you can click and it exposes the boot sector. You can then click it to include it in your cloning operation.

[quote=“flhthemi, post:26, topic:150584”]
Now, you have win 10 running.

Pretty sure my next move was to set the partition for the D: drive to the max size DRIVE MANAGEMENT would allow (default settings).

You might have success if you install Win 7, then upgrade to Win 10 but I think I read somewhere the WD Black² software mucked that idea up.[/quote]

So how did you manage to activate the HDD part? We can do partitioning with other tools. It doesn’t have to be Disk Management or Acronis. That’s not a problem. Why would the first partition have to be exactly 111.8 GB? Is that because the WD software is checking for this? And unless it’s exactly that big it won’t run?

Can you help me fill in the gaps here?

PC: HP Pavilion
OS: Windows 10
Old HDD: Toshiba 500 GB
New SSHD: WD Black2, 120 GB (SSD) + 1 TB (HDD)
Sofware: Acronis True Image WD Edition, WD Black2 installation software
Hardware: Acronis Sata Wire Kit (SATA to USB adapter), WD Sata to USB adapter

Is the Toshiba drive your old system drive? If not, then what is your system drive and how big is it?

Toshiba HDD partition layout:
Partitions: 1
Size: 465,76 GB
Type: Primary

What can you tell me about your old system drive? How many partitions does it have? How big are those partitions?

I saw a 195 MB “system” partition on a 111,79 GB drive in one of your pictures. What drive was that? Is that your old HDD or the new SSHD?

At the risk of making this thread longer…
Here is my system, HP Pavilion 17" Laptop
Came with 2 physical drives,
Drive 0/Disk 1 - 500 gb Toshiba HD
Drive 1/Disk 2 - 500 gb Toshiba HD
I tried cloning Drive 0/Disk 1 - 500 gb Toshiba HD at least 12 times to WD Black2 and it would always freeze 3/4 of the way through procedure. I then tried to clone to the 256 gb Samsung SSD and it cloned perfectly. I installed it into my laptop and it worked fine. The next day I tried to clone the 256 gb Samsung SSD to the WD Black2 and it cloned perfectly first try. I then installed the WD Black2 into my laptop and tried to set up the HD portion of the WD Black2 and could never get the laptop to recognize the HD portion of drive. The 195 MB “system” partition does not show up in Windows File Manager so I’m not sure why it’s there and I can’t delete it in Disk Management so I quit worrying about it. I think it was cloned from the original Drive 0/Disk 1 - 500 gb Toshiba HD. There was originally 4 partitions on that drive. System, Recovery, HP Tools & OS©.

Just unpacking new drive, wish me luck.

Started off real smooth, cloned with WD cables this time and I was really hopeful until I installed drive in laptop and WD software again displayed “No WD SSD found” Grrrrrr!!!


Hopefully photo shows up. I noticed that my Toshiba HD shows “Device Migrated” and the WD drive shows " Device not Migrated" Could this be an indication of my issue?

I am looking at this right now. From what I can tell, “device migrated” or “device not migrated” might be an indication of whether or not a system device was successfully migrated in the Windows upgrade process. I see a lot of complaints on the web about this message and many of them relate to USB devices that are not working under Windows 10, and some of them relate to audio devices.

So, “device migrated” means that the device was… well… migrated, from a previous Windows version. So you had that device connected and working before you upgraded Windows. The “device not migrated” means one of two things. You either had the device connected and working before you upgraded Windows, and now it’s not working, because the migration failed. That might happen in case the installed drivers are not Windows 10 compatible. Or! You connected the device only after you upgraded Windows, in which case this is normal. So it’s up for open interpretation really. But in your case, I think it means the latter.

I am a bit puzzled about the “last device instance id” where it says “USBSTOR” for your WD drive. I think this might have to do with how you initiated the drive for the first time. Remember, you used a USB cable.

So put together, I think this all looks normal.

Have you tried switching SATA mode to legacy in your system BIOS settings? That may or may not be of any help but it’s worth a try. What you do is reboot the PC and press a special key to enter system BIOS settings, change the appropriate option, save the changes and boot back into Windows. The Windows system should automatically pick the appropriate drivers for you. I’m guessing it’s in AHCI mode right now. I would try IDE or Legacy mode. This forces Windows to use a different storage device driver, hopefully one with which the WD software will work.

Is it Windows 10? If it is, this is why, The WD Black² software is NOT compatible with Windows 10. As I explained earlier, you will most likely have to partition the Black² as I have described to run Windows 10 on it. WD does not support Windows 10 on the Black².

I wonder if I unlock the drive on an older PC and then put back in laptop? I’ll try the bios thing as Samirg suggest first as that is quicker.

The BIOS trick I mentioned is a long shot really. But it might be worth it. Yes, the WD software is not working properly with Windows 10. But for what good reason? None!.. really.

So I’m just guessing (I have a hunch I should say) it has to do with drivers and the way that Windows 10 is now working with storage devices. I have seen several good programs stop working with Windows 10, among them is the Acronis True Image, full, commercial version for which I have a proper license and everything. It’s not that it stops working completely either, it runs alright, but it can’t see any of the storage devices, even though they are right there and I can see them in Explorer and Disk Management. So it’s as if these older programs are blinded by whatever changes Microsoft has made to Windows 10.

In case of my Acronis True Image software, it has worked with Windows 8.1 before the upgrade. Now if I want to use it with Windows 10 I will have to upgrade to the latest version, which is an additional cost for me, and it’s not only one license I need to upgrade either. When all it needs is a small update so it can adhere to the way the new Windows works with storage devices so the software can see the devices. Anyway!

Microsoft has definitely made some substantial changes there, to the way Windows 10 works with storage devices, it’s obvious to anyone who has used Windows for more than two decades. I have seen other programs with broken compatibility and with the same symptoms: they just can’t seem to be able to detect any storage devices, otherwise they are all running well and without errors.

Did the SATA mode switch trick work? I don’t know about your particular laptop model (if you post the model number I can check the manual), but there should be an option to switch SATA mode.

I checked some random HP BIOS settings screens on the web and found that some have it under a setting called “SATA Emulation”, some have it under “SATA Configuration”. Other keywords to look for are “IDE” and “AHCI”.

Be sure to change back to whatever setting you had configured previously.

If this did not work, try running the WD software in compatibility mode. Check out this guide for instructions:

If you need assistance with any of this, let me know.

I’m at work, will do some checking tonight.

Just to be sure, let me ask you this. You first partitioned the Black2 and made the first partition 111.8 GiB? Then you cloned the old system HDD onto the 111.8 GiB partition? Did the reported disk capacity (1043.3 GiB) just jump up right away like that or did this appear after you booted up from the new cloned Black2? And you had unallocated space after the first partition where you then created the D partition?

Just checking so I know what I’m doing. This may be the next plan for Andy to execute. If it works, it’s great. If it doesn’t we will have to think of something else.