WD Black SSHD 750GB (Sony Vaio Laptop) not being recognized by any other system

Hi there,

I’ve been grappling with an issue over the holidays that has me at my wits’ end.

I set out to upgrade from the hybrid WD drive in my Sony laptop to a SSD.

I decided to replace the SSHD with the SSD and then complete a fresh install.

I then attempted to use the WD Black SSHD through a USB to SATA bridge adapter but the drive won’t be recognized by any other system.
For every system, the result is the same:
The drive shows up in partition manager as ~750GB of unallocated space.

The drive won’t be recognized by the laptop it was in…
The drive won’t be recognized by my main desktop (running windows 10) when i connect it using the USB/SATA adapter.
I tried connecting the HDD via the SATA ports as well and this resulted in Windows 10 not booting.

I got worried that I had lost all my data so I put the WD Black drive BACK into the laptop and VOILA, hard drive works as intended.
I verified that BITLOCKER was turned off so the drive is not encrypted.

Any idea what could be going on and how I can mount this HDD to be readable by other systems?
I’ve already tried partition recovery tools that have not helped.

Any help would be MUCH appreciated.

Is your BIOS set up using an HDD password?