WD_Black SN850 not detected by BIOS on bootup from power-off

Sorry I meant what is your new board?
I had the msi x570 gaming edge that does not work with the sn850 so I sent it back.
Want to get an asus.

ASUS TUF GAMING X570-Plus (WiFi).

I’ve got an TRX40 chipset and it occurs about 1 in 10 boot-ups from power-off.

I got an ASUS B550-E strix

Seems there is a new firmware available (613200WD), will give it a try.

Still occurs in latest firmware 613200WD on 1 of 2 of my SN850’s.

exactly same problem on MSI MPG B550 gaming plus, never detected on bootup from power-off.
latest bios and ssd firmware;
(SN850 is on M2-2)

tried on m2-1, and now it works fine.

I have the same exact problem you are having. i have WD Black SN850 500GB and Asus B550 mother board. please let me knw if you find a fix.

i reread my Asus manual. the M2.1 slot supports the new 4x4 SSD like the SN850. i moved from M2.2 to M2.1 and it works great. bios sees it now. boots correctly. i did several complete shut downs to make sure.

hello, i had the same problem and i think i’ve found the solution (tip from the wd support). My wd black SN850 1TB system drive was formatted in MBR and to boot in uefi mode you need to convert the drive from MBR to GPT. After this i could deactivate the boot compatibility mode in the bios and boot with uefi.

With activated compatibility mode in the bios its not possible to use the AMD Smart Access Memory technology. So i was forced to convert.

My System:
Asus B550-E Gaming
WD Black SN850 1 TB

Hi used the SN850 Win10 Volume as GPT… from beginning… but it doesnt helped me

Give it another try … updated my B550-E strix to BIOS 2420 (date: 30.07.2021) … put SN850 1TB drive in M2_2 slot … cold boot → DETECTION FAIL

Updated the SN850 firmware to 613200WD and shut down. Started cold boot again → DETECTION FAIL

So this was my last try to get the WD_BLACK running on my system in the M2_2 slot. Now I’m gonna to return this ■■■■ of drive or sell it to someone who won’t use it in the M2_2 slot … anyone who want’s it???

Same issue

I using two

One boots and other one hit and miss

All latest software

on a b550m itx. same prob as everyone else. where and how can we manually update the firmware? starting to get pretty annoying not being able to use a drive that costs a grip

Firmware can be updated within the WD_Black Dashboard:

Same problem here.
MSI X570 Gaming Edge and the WD SN850. Doesn’t detect on startup (most of the time) though other drives including a different SSD in the other m.2 slot do get detected.

Latest firmware for both motherboard and the SN850.

Not only is this a problem on startup but I have a sneaky suspicion that my system is blue screening whenever coming out of sleep, but I haven’t been able to figure out what it really is.

Alex

This appeared to be a disk partition issue when initially installing the m.2. I was able to resolve my issue by doing the following

Prerequisite:
Download the WD dashboard from Software and Firmware Downloads | WD Support

procedure:

  1. Open a command prompt as admin and type DISKPART
  2. enter list
  3. Note the disk number from the dahsboard [mine was disk 4]
  4. enter select volume
  5. enter clean
  6. Convert MBR
  7. Exit

Volume should show on th dachboard and now in the disk management

  1. RightClick the **new volume ** in disk managment and click Format
  2. Select NTFS
  3. Right click again and select ** Change drive lettter and paths**
  4. Select the drive letter you want
  5. You should now see the drive in the windows explorer

In my case it’s not a partition issue. It’s not Windows not recognizing the drive, it’s BIOS.
The drive doesn’t appear in BIOS at all on initial boot but appears on restart a couple of seconds later.

Hello All!

After following this thread for 3 months, I would like to reinforce the original cold boot detection issue!

Asus TUF X570 pro WIFI (Latest Bios to date)
SSD Latest Firmware to date

M2_1 Slot: WDS100T1X0E (1TB) - Linux Boot
M2_2 Slot: WDS500G1X0E (512GB) - Windows Boot

The second (M2_2) SSD is not recognized 98% of the cold boot / power on case. After hitting reset, everything works fine and the win can boot and operate perfectly with proper speeds.

Tried different PCIEGen 3-4 settings, turning off various modules, memory profiles / standard settings, removing other SSD-s and HDDs (with only 2 NVMe installed), indifferent to the cold boot issue.

Let’s continue raising the awareness, I would like to stay with these insane drive speeds without switching to Samsung.