WD_Black SN850 not detected by BIOS on bootup from power-off

Good luck! I’ve been waiting since 20th December 2020.

  1. Their 1st level support is not worth the word support - guess their center is somwhere in India
  2. Some computer magazines like Computerbase wrote about the problem - still no solution

If you can return the SSD - do it, it’s not worth waiting for a fix

I won’t buy a WD SSD again

3 Likes

Wow came here to check again… 16k views… no fix… Get off your ass WD! This is unbelievable. Like others in this thread I wont be buying WD again. What trash support.

2 Likes

RMA the SSD or return it. No other solution.

Just dont buy this drive with amd.
support is just a joke and will send you to a page that tells you to restart your pc from bios everytime you start your pc.
that is not how it should work.

Same issue here, took me a day to get to this point.

Tried on windows 10 & 11 but same issues (later realised it was a firmware or hardware issue)

5600x CPU
x570 MSI Board latest BIOS
WD 1TB SN850 (In slot 1)
RX 6600 GPU

BSOD/freezing after waking from sleep.
Updated drive firmware to 614900WD
Still BSOD and now the drive is sometimes not found by BIOS (reset BIOS needed to get it back).

Same as others when i put the drive in slot 2 it appears more stable, is this a drive problem or a x570/BIOS problem?

Anyone got a solution yet, If not this drive is getting returned.

If you can, return the drive/ssd! The problem exists since the drive hit the market and nothing is done to fix this! This is simply impudence from WD
If they can’t fix their drive, they have to put a warning on the package that it does not work with X570 Mobo’s

1 Like

The M.2 Slot 2 on the MSI x570 board (one connected via chipset) is actually pcie 4.0 (the manual says it is 3.0), so slot 2 can be used without the issues around waking from sleep and bios not seeing the drive and still perform at PCIe 4.0 levels.

Hope this helps someone

Ever since updating my BIOS, I haven’t had any issues after many months and reboots.
I don’t know where the fault is but I would suggest you contacting your motherboard manufacturer for an update. The BIOS update I received wasn’t even published on the website and still isn’t. I think there is a known problem here, but not widely published.

1 Like

Just heard back from WD and MSI, MSI told me to wait for a response from WD, note i have not tried this yet, and notice the link is dead (not a good start), i prob will leave my SN850 1TB in slot 2 wher eit works.

WD response …

Thank you for contacting Western Digital Customer Service and Support. My name is Pietro M…

Try changing the driver to Intel Rapid Storage Technology (IRST) for temporary work around.

Here’s the steps to switch to IRST driver for WD Black PCIe SSD:

  1. Check if you already have IRST installed:
  • Go to Control Panel , Uninstall or change a program, and check if Intel Rapid Storage Technology is present. If Intel Rapid Storage Technology is available go to step 2

  • If you don’t have IRST installed, download and install the driver from official MSI website: https://us.msi.com/Laptop/support/GP72X-LEOPARD-PRO-7th-Gen-GEFORCE-GTX-1050TI.html#down-driver (if you are using MSI official image that came with the PC there is no need for you to download and install this driver, it will be included in your image)

  1. Restart your PC and repeatedly press Delete key during MSI boot screen to enter the BIOS
  2. Press right arrow to choose Advanced tab
  3. Enter to select SATA Mode Selection, press down arrow to choose Intel RST Premium. Press Enter to select the option
  4. Press right arrow to select Save & Exit tab
  5. Enter to select Save Changes and Reset option. Enter again to confirm Save configuration and reset? message. Proceed to boot up the laptop as usual

After the change is made, you can go to Windows Device Manager to verify the correct driver is being used:

  1. Right click My Computer
  2. Click on Manage
  3. Click on Device Manager
  4. Collapse Storage Controller option and check the name of the storage controller. The storage controller driver should display as Intel Chipset SATA RAID Controller

If this doesn’t help, please provide the following information, in order to better assist you:

  1. Where are you using the WD drive?
  2. Is the drive detected?
  3. Can you provide any photo of the error messages that appear?
  4. Did you change anything in the drive or the environment around the drive?
  5. Is the drive installed in your computer internally or externally?

If you can, send the drive back!

Neither MSI nor WD take care of the problem since December 2020.
But my Samsung and Crucial Nvme SSD work without problems in slot 1.

Conclusio: It is a WD problem and the customer service is not good to be polite.

As I said a few times: I do not buy WD products anymore, until they fix their customer support

Sent it back as Im not risking it looking at the time they have known about this issue and still not got a official fix rather than a workaround, it suggests there maybe more to it than just needing another firmware update otherwise you would expect it to have been sorted by now?

Got a firecuda 530 in the end, works flawless in m.2 slot 1 on the msi -a pro x570, the WD sn850 is on its way back!

I have the same problem with SN750.

SN750 1TB on m.2_1 - works all the time.
SN750 2TB on m.2_2 - hit and miss from cold boot.

Config:
AMD 5600x
Asus ROG STRIX B550-F GAMING

Hi, I have the same problem here, X570 edge wifi mainboard, ryzen 5 3600x CPU, SN850 NvMe SSD.
Booting in Bios no recognition of the SSD. If I exit the Bios the system reboots normally into windows. Any solution yet ?

Lawsuit incoming

I just recently had the same issue since I changed my motherboard to MSI X570 Gaming Plus.

I haven’t had any issue with my previous mb MSI X570-A Pro. The SN850 works fine in the old one which was given up lately.

I never thought this would be the issue. Have tried to update both SSD firmware and BIOS. None of them helped. Very sad to know this has been the issue with a lot of people for years.

So at this point I feel bad recommending these SSDs for my friends and family. Out of 7 Builds in the last ~2 years, I had 5 of these issues. Returned / Replaced 9 of these drives (including my own 2).
The SSDs are working individually and with other branded SSDs in pair, but not 2 SN850 at the same time.
This silence and no-comment attitude from WD is not acceptable, so I have sent all these drives back. Running on Kingstons and Samsungs for now.
I was big supporter of SanDisk before, I had many great drives from them (some SSDs are 10+ years old, still kicking), and the fact that these drives (SN850) still had SanDisk controller in them made me buy these WD products. But sadly that SanDisk quality is gone and butchered. Good Job Western Digital…

1 Like

So after 2 months I decided to change one of the SSDs.
I exchanged the SN750 1TB for a Samsung 980 PRO and now everything works perfectly.
Samsung runs without problem on both m.2_1 and m.2_2.

Before that, both the SN750 1TB and the SN750 2TB had problems on the m.2_2 port.

I don’t recommend WD SSDs.

1 Like

Iam here to confirm the issue is the drive. I have intel 12th gen. 12600k. Newest board for intel cpu. Sn850 died out of nowhere. No longer detected in bios

Literally put together my new pc yesterday with the same motherboard you’re having the problem with.

One strange thing I noticed is sometimes the led comes on on the ssdrive when it’s not detected, don’t know if this might be a clue as to why it’s not working?

Majorly annoying when you outlay pretty big bucks on a ufo pc and it’s unusable.

I’ve got a feeling the problem only started after I plugged in a sata 3.5 hdd.