WD Black not detected on reboot


#61

My hardware is WD2003FZEX-00SRLA0 and m/b asus prime z270-plus. Windows 10 ver1703.
It failed soft reboot too.
And, btw, it has worked properly for 3 month with m/b asus P5QL-EM, Core 2 Duo 7300.


#62

i have been having these issues also. for day to day use i have no issue. when windows has a large update my drive starts disappearing in windows and the bios. i just did a fresh install of windows and i had to remove the wd drive as it was forcing my in a endless loop. it was just a storage drive but it was still making issues till i removed it.when windows forces restarts during updates the drive just disappears.

i am using a asus hero alpha mobo. please share the fix for this with me


#63

Helpful thread, Thanks great info on external hard drives in this thread.


#64

I am having this issue with a WD Black 2TB WDC WD2003FZEX-00SRLA0 drive on a 170x Gigabyte Gaming 5 rev. 1.1 motherboard. I built three of these systems in August of last year, and it’s happening on all 3 systems. They all Boot fine, but on restart the drive disappears.

It started sometime after the Creator Update. One machine, this one, has had a BIOS update done, firmware updated, AHCI driver updated, and nothing fixes it. None of the settings were changed in BIOS.

When it happens, if I restart the drive is gone from BIOS. I shut off the machine, turn it back on, the drive appears in BIOS in the wrong boot order. I fix it, save it, and it’s fine again until I need to restart. If I simply power off and turn it on, it’s fine. There are no SMART errors, no difference in performance.

I put a ticket in to WD, who advised that my BIOS settings must be wrong. I explained in my initial ticket that this thread existed. I think it’s strange that all 3 systems have this issue, and all three systems were working fine for nearly a year. I hope something can be done. I have also put in a ticket to Gigabyte, and am still waiting to hear from them.

I have tried enabling hot swap on the drive, and for the first time in weeks restarted normally! Please fix this!


#65

I don’t understand why WD doesn’t just write the fix here for anybody who encounters this problem. There’s a simple registry change which fixes this issue without having to turn hotswap on in the bios.


#66

I had same problem with mine 2TB WD Black WD2003FZEX-00SRLA0.(W7, 64-bit)

After I downloaded and installed latest Intel driver for Rapid Storage Technology , version 15.7.0.1014,problem dissapeared and BIOS is finding mine WD disk during reboot without problem.:grin:

Here is the link:

https://downloadcenter.intel.com/product/55005/Intel-Rapid-Storage-Technology-Intel-RST-


#67

I did try the newest Intel RST, and that did not fix the issue.

Interestingly enough, I came across a Reddit post that said to try restarting in safe mode and then restart again normally. Lo and behold it fixes the issue completely. I don’t know why or how, but it works.

Something seems to cause UEFI to go into default mode, and it has happened on all of our computers. Sometimes it happens after a Windows 10 update. Resetting the UEFI to appropriate settings, sometimes brings back the restart problem, and then booting into safe mode fixes it again.

If there is a registry fix, yes I’d like to see that too.


#68

what happened to this?
Bill_SWDStaffJan 4
We are following up on this and will be in touch with those of you having the issue through private message.

i have not been contacted by pm. are you guys not longer following up on this issues? many of us still have this problem and would like whatever this fix you guys have for it . please


#69

After install new Intel RST driver go to Control Panel- Intel Rapid Storage Technology and click on Performance tab .There click to Disable Link Power Management. Somehow it affect BIOS ability to recognize hard drive during reboot.


#70

Yes I’ve done that, and unfortunately the drive would still go missing on restart. It’s like something is causing loss of settings somehow.

Safe mode seems to be the fix that gets out of it anyway until it happens again.

I can restart and my drive is found, until it isn’t. Again, this has happened on three similar computer builds. Kinda crazy!


#71

My Black WD6001FZWX is on the fritz again… has been fine for the last few months and now once again unavailable, not recognized on reboot, etc.
WD’s apparent disregard for this issue would seem to indicate that it is a) beyond their control or ability to diagnose or b) they are actively “encouraging” customers to convert to SSD, at higher costs and data lost. Goodbye, WD.


#72

Anyone find a good fix for this yet? It’s driving me nuts and scouring the web hasn’t resulted in a fix for the issue.

Thanks!


#74

Any good solution Bill_S?


#75

We are having the same problem on Mac Pros running El Capitan. WD, have you created a patch for us Apple users too?


#76

Dear Sir
hdd spin fist check -sping not problem hdd
not sping hdd problem

solution : pcb or sa or cables or other system


#77

Hi,

Seems like I am also having a similar issue with my drive on a X99 motherboard with Window 10.
I read through the thread, and I can’t seem to find the registry entries people are talking about.

Could someone post or repost them?

Thanks in advance!


#78

Hi,

Same issue here, asus M5A97 motherboard and WD black WD30EFRX drive.
It worked fine until formatted as GPT then reboot and it was gone from bios. Drive was a replacement for WD red drive.
I’m slowly losing faith in WD drives even though I’ve been buying them since it was normal to install a 200 Mb drive. I just want one that actually works!!!


#79

I had same problem on ASUS Rampage V Edition 10 Motherboard. Only helped to turn off PC and reconect SATA Cable. Before that I had WD Blue he didn’t make problem but that was SATA II AAKS.

Solution is to uninstall IRST Driver.
After that problems gone. MS Driver is newer, and you will not recognize difference.

I strong believe in WD HDD and I want to send them message to continue with their quality products.
WD now launched two models WD Black with 256MB, they are probably better optimized with last Windows 10 Updates and probably firmware is better. FZEX is 5-6 years old and still is top performance.

WD Black WD4005FZBX 4TB
WD Black WD6003FZBX 6TB

Same as Gold series 8-10-12TB with 256MB.
Soon I will upgrade little capacity from 2003FZEX to WD4005FZBX and choose one WD My Passport Ultra 2017 2TB 13.5mm size. Together they are cheaper than 1TB USB 3.1 My Passport.

Only WD need 2TB 2.5" WD Black 7mm.
They could be used and In desktop PC in 3.5" bay in RAID Mode.
There is a different cases for that.


#80

Hi, I suddenly got problem with my WD black 2tb hdd. It just disappeared from the explorer, and doesn’t show in disk management and the bios shows unknown. It was 3 year old only, some of my other hdds are more older, maybe 6 years are more old but still working normal.

My motherboard is not Asus, it’s Gigabyte GA z270x gaming k7, i7 7700k cpu. Please advice me what I can do…

Thanks


#81

Just bought a WD Black 4TB (WD4005FZBX-00K5W01.0) - hooked it up to my X99A/USB-3.1 motherboard. I had a Blue already in situ and I boot from an NVMe. Immediately noticed the drive didn’t show up on boot, but a reboot fixed it! Running Windows 10 1803, latest motherboard firmware from my SI.

This is a reproducible fault - if I cold boot, the Black HD doesn’t show up in Windows as a device. If I subsequently reboot, the drive always appears. This is really annoying and incredibly inconvenient.