WD Black not detected on reboot


#21

Wow, I’m so relieved I’ve seen this thread!
I bought a new WD black drive 2 weeks ago, and the drive not being detected after a restart was driving me nuts!
I almost bought a new PSU because of this.
I have 3 more WD black drives - All WD2003FZEX-00Z4AS0, and they all work perfectly - detected all the time.
Only this one WD2003FZEX-00SRLA0 is almost never detected after a restart, only after shutdown.
My motherboard is Asus Z170 Pro Gaming with the latest bios firmware.

As I see there is no attention here in this thread from WD staff for over a month, I’ll also open a support ticket, to find out what should I do about this.


#22

This issue obviously relates to the WD Black FZEX-00SRLA0 range of drives. I was asked to add some registry entries to my Windows 10 Pro which have made no or very little difference. I get around this problem by delaying or even avoiding reboots as far as possible. But when I do reboot I just cross my fingers. The PC takes much, much longer to detect the drives (compared to my old WD 2 TB Black FAEX suffix hard disks which were detected immediately) but the BIOS eventually does detect the drives and the PC boots up normally.

The replacement drives are now about 6 weeks old.

There IS a problem with the drive or the firmware. The sooner WD accepts it the better for us all. It is simple - a motherboard(s) that works perfectly with other SATA products from WD and other vendors cannot be to blame. Drive physical or firmware/software defect? I can’t tell for sure. All I know is should I RMA these drives I am quite certain of receiving replacements with the same problem. On top of this uncertainty is the task of backing up and restoring TBs of data which is no fun at all. So I’ve held back from a creating a new RMA.


#23

Of course it’s not a Windows 10 issue. It’s a firmware issue.


#24

Update on the C0/192 Power off retract count.
Ever since the bios was changed to set the drive as “Hot-swap”, the count has not increased.
I also have a Z87 Asus board with an Intel Z87 chipset with the exact hard disk in it (level 00SRLA0) and there are no problems with this configuration.
Not “Hot-swap” and fast boot is enabled.
I added this just in case WD support is actually looking at this thread.


#25

We are following up on this and will be in touch with those of you having the issue through private message.


#26

Hi,

After much Googling I finally found this thread. I have exactly the same issues… Hard Drive only detected from a cold boot, or starting up after a Windows shutdown. But never from a Windows 10 instigated restart. Rejigging SATA cable arrangements do not help.

Motherboard: Asus Deluxe II X99
OS: Windows 10 Pro 64-bit (Version 10.0.14393 Build 14393)

Model Number: WDC WD2003FZEX-00SRLA0
Unit Serial Number: [Deleted]
Firmware Number: 01.01A01
Capacity: 2000.40 GB
SMART Status: PASS
Test Result: PASS
Test Time: 16:48:25, January 06, 2017


#27

The issue is fixed by a registry patch which disables energy saving on SATA channel. I don’t like this fix very much because It changes something into Windows and not into the hdd firmware which is the real guilty.


#28

Just to be sure the registry entries actually had no effect on the drives, I deleted the previously added entries powered off the PC and restarted it. Once Windows loaded I did a manual restart. No change, the BIOS halts at the boot screen and takes approx. 6-10 seconds to detect the drives.

I am convinced this is an issue with the drive firmware because:

a) Every other SATA drive whether it’s a hard disk (including models made by Western Digital), SSD or optical drive is detected immediately
b) The registry entries make no difference; evidenced by no change in the drives’ behaviour
c) BIOS settings are at default & the PC has not been overclocked.

I am planning to upgrade my 2 TB Black drives to 4TB Black in the next 1-2 months. And I sincerely hope I don’t face these drive detect issues. Cause that would be very disappointing indeed.

PS - It’s now nearly 2 months since I reported this problem. Have WD’s technical support/development team(s) made any headway in ascertaining the cause and solution?


#29

Actually the registry settings do make a change. you just have to do full shutdown after you set them and then in the next boot Windows will apply them, and the next reboots the drive will be detected at startup. At least for me that’s what happened. I initially restarted after adding the registry change, and it again didn’t detect the drive. I thought “baah, it doesn’t help”, but then I remembered that Windows needs to apply the behavior in its startup, so after a first boot to Windows with the new registry settings all restarts now run with no problem anymore.
But I do agree it should have worked at default settings like other drives do.


#30

I added those entries to the registry a few weeks ago. In this time the PC has gone through daily power off and on cycles. Deleting the entries has made no difference as I mentioned in my post.

I am told this set of registry entries works better with the Intel X99 but not the older Intel X79 motherboards. IMO, these drives should work just like any other standard SATA drive without the need for any registry tweaks.


#31

Where can the registry fix be found?

I use the hard disk as a secondary drive (i.e. it is not my C: drive). Is the fix any better than setting the drive to be hot swappable in the BIOS?


#32

The registry entries are reported to work on X99 mobos. But YMMV of course.

They were emailed to me by WD Tech Support. I could share the registry file here but not sure if I am permitted to do so under the forum rules.


#33

I have the same problem with my WD6001FZWX-00A2V (WD Black 6TB). Enabling hot-swap “fixes” the problem for now.

Motherboard: MSI X99A GODLIKE GAMING with the latest bios version 1.8.
OS: Windows 10 Pro 64-bit

I’m also interested in the registry fix. Any willing to share?


#34

Registry fix vs. hot-swap.
The registry fix worked on my motherboard, but looking at someone else’s entry it may not work for all.
I found no difference in system performance between either work-arounds.
The hot-swap method is easy to do in the bios and does not require a registry change, something many people don’t like to do. A subsequent OS upgrade or whatever change may reset this registry value to default.
IMO, just apply the hot-swap method and forget about the registry.
This is something WD support should be playing with to get their problem resolved.


#35

I didn’t like the hotplug fix, cause then you can see all the partitions in the device manager listed as “portable devices”. Don’t know why, but for some reason it bugged me :slight_smile:
I prefer the registry fix, and I keep the old and new reg texts here, so I can edit the change in time of need…


#36

I have a good new: the new SSD m.2 finally arrived and so now I installed WIN10 again in it as first boot. And… the WD Black now works fine, even after a reboot. So in my situation there’s the issue only if I use the WD Black as O.S. drive (Asus Maximus VIII Hero Z170 chipset and BIOS 2202).
So no reg fix and no hot swap work-around. Just installed WIN10 in the Samsung 960 PRO and everything works fine (and much faster…)


#37

Since you reinstalled and your issue is now gone. Has anyone else tried this? I am using a WD 2TB Black drive as a data drive and i am having this issue. I thought it was defective as it has a weird sound but i’m wondering if i am having the same issue that you guys are having. Has anyone tried to reinstall and see if that fixes it?


#38

Where is the OS in your pc? Still inside a SATA drive or m.2? I think it can be different.


#39

My current solution for my setup (Asus X99 Deluxe II, , 2x WD black 6TB) is to disable SATA LPM (Link Power Management) in the Intel Rapid Storage Application. This is basically what the proposed registry changes do, just via the application UI. This does not have the drawbacks of the “configure drive as hot pluggable” workaround that I used before to keep my WD drivers visible after a reboot. Note that this solution probably requires to have the Intel RST driver installed and may or may not work with the standard drivers that come with windows.


#40

Glad to find this thread, same situation and I was pretty sure it was the drive but was wondering about the mboard. Glad others have contributed already.

WD wd6001fzwx (Black 6Tb), ASUS mboard. This is a secondary drive for storage. On a regular boot no issues, drive is fine. Coming out of sleep mode loses the drive, Windows explorer sees the partitions but freezes while “working on it”. Same with a restart, either the BIOS hangs or I have to do a full cold boot.

Have tried swapping ports on the mboard, will try the hot swap mode in BIOS. Up until now I thought WD was a reliable brand, not thrilled at the prospect of my data occasionally vanishing.