WD Black FALS - second drive is also bad?

I bought a WD drive last year, had it 6 months before it quit working. I just decided to toss it (got it on sale). Earlier this year, I purchased another WD drive and again, it failed, but in only 2 months. This one I RMA’d and received a WD black FALS drive. Well, it seems that this one is going to give me problems after only 3 months. The drive will be listed in “my computer” and then when I’m going something, whatever I’m doing, seems to lock up, then when I look, the WD is no longer there. 

The Diagnostics program is no help either. I keep getting an error code that is not listed and gives no explanation what is going on. The Quick test doesn’t work, fails, giving me yet another code that isn’t listed. I really don’t want to go through the whole RMA garbage again, just to get another drive that doesn’t work (even if that is possible - can you RMA twice like that? Humm)

The quick test gives me the error:

06-Quick Test on drive 2 did not complete! Status code = 07 (Failed read test element), Failure Checkpoint = 97 (Unknown Test) SMART self-test did not complete on drive 2!

the extended test:


 - and that is all.

Any suggestions would be welcome. Thank you in advance  :slight_smile:

(I own a Western Digital 850 megabyte drive (yes, MB) that still works. So what happened to the WD quality?)

I sent the second drive back and *yay* received a new drive.

I plugged the new one in and started windows setup - "windows cannot install - drive is damaged*

So, I tried several times more and finally got windows to install. I loaded Sims 2 and when I was finished, I turned off my computer. When I turned it on again, windows would not start. I checked bios and it is not recognized. I tried restarting several times but still nothing. The drive has quit working completely.

I know that I am not doing anything wrong because the drive I am using now is working fine and has been for a few years.

So - now what? Help???

Hmmm…3 HD Drives in the same computer failing? Double check your Power Supply.

Nothing wrong with Powersupply. I tried the drive in another computer and it still didn’t work. I tried a different drive in this computer and it ran fine.

When a person purchases a product, they expect it to work. I bought a drive and it did not. I sent it back and they sent me a replacement. Four replacements later, I thought I had a good drive. This morning the drive suddenly vanished from “my computer” but is still recognized by BIOS.The Data Lifeguard says that there is nothing wrong. I cannot get it to work. It is dead.

I give up. I’m done. I’m tried of trying to get a good drive - just one that works would be great, but I’m afraid I’m not going to get one from WD. I’m out a small amount of money (about $50 - not really a small amount, but I’m trying to see at least one bright side in this) and a year of my time. Being stupid, I thought this one was working and moved some files to it - I have lost them all.

While customer service is excellent, the products are not.  From now on, I will buy another brand.