WD Black drives in RAID?


#1

Is there any way to update the firmware to be able to set my drives up in RAID? I specificaly purchased 3 1TB WD1001FALS drives to do that with. Nowhere on the box or any of the manuals, installation guides or anywhere else for that matter does it say that these drives are not good to use in a RAID configuration.I found out purely by chance by reading a post in another forum that these drives supposedly are not compatible with RAID.

If it is possible, then fine, but if not then I have a big problem with this. I would have  no problem spending a bit more to acheive this. But now I’m out over $300, this is unaccepateble if that’s the case.


#2

I just got burned on two.  Took me two weeks to discover that WD had disabled “time-limited error recovery” on these drives.  If the DCM ends in AB you can still turn on TLER with the secret WDTLER utility.  If the DCM ends in CA it is permanently disabled.  My drives came from adjacent holes in the same OEM egg crate and I got one of each.  Earler versions are already TLER enabled.

Do not do RAID with new Blacks.  You will experience performance degradation, data corruption, and data loss.  You have to spend 60% more for RE drives.  I was told Blacks are underachieving RE’s.


#3

Me too, I’ve got a couple of 1TB Blacks (WD1001FALS-00E8B0, all manufactured 25 nov 2009) in a RAID-5 and just enabled TLER on all of them. Their DCM numbers ended quite differently, I had one AB, one CA, one AA and two CB. Running TLER_ON supposedly worked on all of these (even the CA), since a new TLERSCAN gave me the “set to 7.000 seconds” message. Does anyone know another method of checking whether it’s worked?

So TLER capability maybe isn’t related to the DCM number? Or maybe something didn’t work, could be. The first TLERSCAN per two-disk set gave me quite a list of errors (after stating that TLER was off), but the second one was ok…

I’ll wait if I get into trouble. I’ve got backups. And when things start to go bad, I can still buy REs.


#4

Tell me more about the secret WDTLER utility. I have two of the 1TB blacks for a raid 1 and would like to see if I can still use them.