WD black 4tb drive not spinning

Hey i wonder if anyone has a suggestion for a problem i have,

i purchased a WD black 4tb drive quite a while ago to use for backups, i recently tried connecting the drive again and it doesnt seem to spin or do anything, obviously not showing even on bios since its not spinning, at the time i had it in a hdd dock so i just guessed it was one of them drives that is incompatible so i connected it internally SATA and power and ended with the same result.

a drive not spinning up at all seems like a busted drive but this one has only been used once or twice in the past couple of years barely done more than initialize it and backup a few files.

am really hoping it can be saved but i suspect its dead just wondered if anyone had any suggestions for trying to access it at last once.

thanks

Edit: looked up when i actually bought this drive , 22 Jan 2013 13:26:00 , , its an OEM drive but looking at WDs warranty info the code ,WD4001FAEX, appears to come under the WD black 5 year warranty so if this drive really is done for i might try that

Hello,

If the drive is an OEM that came with the computer, the warranty is not the same as a drive that you buy at a store.

As a recommendation, create a case with WD to confirm the information about the warranty of your drive.

Cheers
i build my own machines so the Drive is an OEM one purchased from a store alongside other components so it Might have warranty im not sure (edit: have just checked and it is in warranty have 362 days left so thats cool)

i just have to try and decide it the data on it is important enough to try doing data recovery or not…