WD_BLACK 1TB AN1500 NVMe Linux Out of the box

Hello,

WD_BLACK 1TB AN1500 NVMe Internal Gaming Solid State Drive SSD Add-In-Card - Gen3 PCIe, Up to 6500 MB/s - WDS100T1X0L

Anyone tried this card with Linux? If so does it work out of the box? I mean no drivers no nothing just shows up like /dev/nvme0 or something like that?

If NOT can you recommend a PCIE SSDcard which is absolutely plug and play no bios no nothing just works out of the box just like you would plug in a regular SATA drive, I need this for a server.

Thank you.

any linux WD users? bump

@droodx
I am not a regular user for AN1500 on Linux, but I have a 2TB unit. I dropped that into an OpenSUSE Tumbleweed install and it showed up as a NVMe device just like I expected. I expect it should work in that capacity anywhere.

I originally tried to install Linux directly onto the AN1500 and boot from it. That did not work as well. The installation succeeded but the BIOS doesn’t see the AN1500 drive so I don’t get a boot option for it. There is some guide on the support site about configuring for this but I did not dive into the BIOS on the system I was using. Here is that guide for reference How to configure WD_BLACK AN1500 NVMe SSD ADD-IN-CARD as a boot drive for new OS install and existing OS..

Oh, and I should mention WD does not provide any software for controlling the RGB on Linux. The only application provided by WD is Dashboard, and that is only released for Windows. You will need to use a Windows environment to set the color scheme you want before installing to your Linux system, or find a different software. The default color scheme is rainbow.