WD Backup Software won't run (Windows 10)

I have an external WD easystore hard drive i use for backing up my data on my computers at home. It works on 2 of 3 computers. My ASUS laptop will not run the WD backup software. I have tried uninstalling all of the WD software, rebooting and re-installed the WD software and WD backup software does not run even thought my computer recognizes the WD easystore hard drive and the WD utilities works and recognizes it. What should i do?

3 Likes

I am in the same boat and had posted on topic on this. This is interesting. I have tried their suggested steps. I have no issue on a PC but I too have an asus laptop.

I ended up calling Tech Support and they had me delete the old backup files from my laptop and then re-install the WD backup software and then it i was able to run the software to perform backups. Thank you Tech Support!

1 Like

@chenjiawei

1 Like

Did you uninstall WD back up first then back up files? Which back up files are you referring to?

1 Like

I uninstalled the WD Back up software first and uninstalled the .wdc folder on the C Drive the re-installed the WD back up software from the Western Digital website.Can’t remember exactly if i missed any steps but just call Tech support and they will talk you though step by step to fix this issue.

what is the tech support number you called?

WD Tech support